Commando searching remote files

I use windows as my host machine and Linux / Ubuntu as my a virtual machine on virtualbox. All my dev work is on my ubuntu vm. I set up a remote connection via ssh in Komodo IDE so I’m always editing files directly on the VM.

Everything works perfectly, until it comes to searching. I’ve tried using commando but I can’t seem to get it to search inside the remote connection. Even if I right click on a folder in the “places” tab, “find” and “replace” are greyed out of the menu.

I know 1 solution would be to set up a shared folder between windows and ubuntu, but I want to try avoid that if commando can work / search in the remote connection.

Is this possible at all?

PS: I have asked a similar question before but it is still unanswered:

AFAIK Commando can’t search in remote files. I don’t know the real reasons why it cant do that, but I guess it’s because it would be very slow in case if your connection is also slow and just hard to implement.

Ok, fair enough. I guess I should set up a shared directory then. Thanks.

Right, it’s just too slow to query remote files. That’s not to say it can’t work but it would involve a whole lot of caching and it’s not something we’re currently interested in supporting. That said it’s not that difficult to make your own Commando scope, eg:

1 Like

I have tried the 3 different options:

  1. I tried having a shared directory, but this caused a heap of other problems. For example: File ownerships took me hours to work out how to assign correct ownership with mounting (as the “chown” command doesn’t work), linux packages like npm don’t work well in the shared folder and I am unable to create symbolic links within the shared folder, so that’s a no go for me. On top of that, changing directories in putty is far too slow inside the shared folder.

  2. The server scope plugin seems promising, but whenever select it within commando and try search for something, I am always getting “No Results”. Any idea why?

  3. I would like to try the projects scope, but when I try to create a project Komodo opens up my windows file system to select the project folder, so how would I create a project by selecting a directory inside my VM server?

The servers scope allows you to connect to servers, it lets you search through your available servers, not what they contain.

The projects scope works the same way, except it allows you to switch projects.

Neither scope addresses your issue, I linked to them to give you a reference in case you wanted to create your own scope.

1 Like

Ok, I’m with you now. Yeah, unfortunately my development skills are not on the level of creating Komodo plugins just yet :slight_smile: But I’ll look into the documentation anyway. Thanks!