Colour scheme not applying

I am a new user of Komodo Edit 12.0.1. I am trying to customise the colour scheme to make it easier to read my scripts etc. I have setup a colour scheme in the editor and this works for one of my previously saved files, but it does not apply to other saved files or indeed newly opened ones.

I have tried deleting the doc state xml file. I have set the preferences to show whitespace.

Please can anyone help.

Morning @ruthw,

Could you try to reproduce the issue in Safe Mode? Help > Troubleshooting > Restart in Safe Mode.

If you’re still able to reproduce in safe mode please provide step by step instructions on what you’re doing. From what you’ve shared I can’t tell what might be going wrong.

Also share your logs: Help > Troubleshooting > View Log File

  • Carey

Hi Carey,

I did…
help>troubleshooting>restart in safe mode
new file (pasted in script)
tools>colour scheme editor>new> set up new scheme, clicked apply-save

But text in script does not change colour.


I’m not able to reproduce this:

I get the same result if I instead create a New scheme.

Do you perhaps not have Editor selected when you click Apply?

I followed you exactly. It works on one file but not another.

I have only ‘Editor’ selected when I click apply.

Doesn’t work on brand new files

Hi @ruthw,

We need to dig into what is unique about your setup or work flow since i’m not able to repro the issue and no one else is reporting it. Please try to provide as much detail in your response as you can.

Can you share your logs? Help > Troubleshooting > View log file

Whats the difference between these files? How are you opening the file? Please provide any details you might think are relevant or odd/unique to your env.

What kind of file? JS, Python, text? How are you creating the file?

They are both txt files. I open them via File > Open
I’m using Komodo Edit 12.0.1 on macOS Catalina 10.15.7

I found the log file, but cannot seem to save it and pasting it here gave me errors.I followed the File path, but I don’t have KomodoEdit in my application support, maybe that is the problem?

Aww this would be why. Text files don’t get syntax highlighting. There is no syntax to highlight. You need to open a specific languages file type.

So for example you can try on Mac:

  • Cmd + Shift + n (open file template)
  • choose a Python file
  • type import os

You’ll see syntax highlighting then.

import os
  • Carey