Color tooltip

Noob feature request here – it would be really nice to have the color preview appear when we mouse over a color code (the feature is built-in to Brackets and Dreamweaver). Of course, accessing a working color palette would be fantastic, too.

I love how, in Komodo, I can tab out of a completed element (ie: class=“container”) without actually adding a tabbed space between ‘container’ and the closing quotation mark – just a nice touch by the Komodo team.

Thank you.

Hold Ctrl and:

  • hover on a color to get the tooltip.
  • Click on a color to get the color palette window (You can change the program to use in Preferences - Fonts & Colors).
1 Like

Thank you. I should have mentioned that I’m on a Mac running OS X ver 10.11.

Based on your advice, I tried using the Command key & Control keys separately – I’m not getting any response. Is this known to work in OS X?

Thank you again!

Sorry, I don’t know, I’m a Linux user, not an OSX user. @nathanr?

On OSX you use Cmd+Hover. Depending on the type of file it may not work though. What are you trying to use it on?

I guess he’s trying to use it in a HTML file in style attribute of any tag.

That should work actually. But is he actually using a HTML file? Maybe it’s some type of templating language.

[edit] Yes, it was an .html file. [/edit]

The problem may be just that I’m running a beta version of OS X here. I am glad the feature is included in Komodo Edit, though.

I just tried again with the linked file – no luck. But, you see what file I tried it with.

I appreciate your input, guys.

I am running the El Capitan beta myself so that should not be an issue. I was able to get color previews for both colors in the snippet you shared.

So just to confirm a few things:

  • You are running Komodo 9.2.1
  • You are using that snippet posted above and selected the language “HTML5” from the statusbar dropdown menu
  • You are holding the COMMAND (not CTRL) key on your keyboard and hovering your mouse over the color values
  • Nothing happens …

Do you maybe have hyperlinks turned off? Ie. Preferences > Editor > Smart Editing > Hyperlinks.

I am now; there was an update a few days ago to 9.2.1. Finally had a chance to try it again, and all of the color tooltips work in other files, as expected.

Thank you for your help, guys!