Can't launch Komodo IDE debugger from IIS7

I have tried to launch the Komodo Perl Debugger from Browser through IIS 7 to step through the script in Komodo. Perl script is executed correctly but nothing happen in the Komodo IDE even though the break point is set in the script. Has anybody gone through this exercise? Please help.


This issue has been resolved.

How you solve this?

Step 1. Open ActiveState Komodo IDE. Go to Menu Edit -> Preferences. Expand Debugger and click Connection. Click radio button "a specific port: " and enter value 49298 or any unused port number

Click OK to save the value

Step 2. Go to System -> Advanced System Settings and click Environment Variables. Create following variables with appropriate values.
1.PERL5DB = BEGIN { require q(C:/Program Files (x86)/ActiveState Komodo IDE 8/lib/support/dbgp/perllib/ }
2.PERLDB_OPTS = RemotePort=
*Values depend on where Komodo IDE is installed, RemotePort number has to match the listening port in the debugger.

Step 3. Go to IIS manager and the site where Perl Script is called. Open Handler Mapping and open handler “Perl for CGI”. Modify value of Executable as c:\strawberry\perl\bin\perl.exe -d “%s” %s

Step 4. Restart Computer

Step 5. Open Komodo IDE, click Debug in the menu bar. Click “Listen for Debugging Connections”

Step 6. Open Listener Status, and verify the Debugger Listening = Yes

Open Browser to point to the Perl script. The Window of Komodo IDE will Pop up asking permission for connection

Click Yes to accept the connection and begin step through the code in Komodo

1 Like