Can't exclude directory from code intelligence

I’m using Komodo IDE 8.5.3 for a Symfony project (in case you don’t know, Symfony is a PHP framework).
I want to exclude the framework cache directory from code intelligence, since it happens a lot of times that a reference to a method/class goes to cached class (that is not good). So, in the project properties, in “Files and directories to exclude”, I added ;app/cache in the end of default value.
That’s not working: when code intelligence runs, I see that files in cache directory are still parsed, and I still go to such files when I click a method or class.

Could you try closing and reopening your project to make sure the prefs take?

And of course we know about Symfony … (that’s an orchestra thing right? ;))

If you disable the Code Intelligence > Include all files and directories from the project base directory preference, then you can add your own custom PHP > Additional Include Directories (on the project preferences) that will be scanned by Komodo code intelligence.

Note: Finer grained control over files/directories being scanned has a Komodo enhancement request:
https://bugs.activestate.com/show_bug.cgi?id=74765

Cheers,
Todd

Todd’s solution is a good workaround.
Not perfect, since I lose the opportunity to add classes inside app directory.
That bug is ridiculously old, hope it will fixed soon.

Thanks