Can't debug tcl

Using a new computer at work and I’m using Komodo 8.5.3 and tcl 8.6. If I choose run without debugging the script executes just fine, which means Komodo can access the interpreter. However, when I run with the debugger, it acts like it’s starting, and just hangs with the “Debugger is running…” If I pause, the script breaks at line 1. If I choose step, it still hangs with “Debugger is running…” and hitting pause I’m still at line 1.

Anyone have a clue what’s going on here?

Can you show your Tcl language preferences and log after running debug session for tcl?

Please download the latest Komodo. If you’re hitting the issue that I think you are, it’s been resolved.

Please let us know if the latest build doesn’t help though.

  • Carey

Hmm, 8.5.4 is not a new major update… So you did not enable auto-update from 8.5.3 to 8.5.4?

Auto-update is always on @Defman. As he said, he’s on a new computer and installed Komodo 8.5.3. They will get a request to update over the next few days I’m sure but why wait?

  • Carey
1 Like

Yub, using Help > Check for Updates menu should get you to the latest Komodo 8.5.4 version. Please let us know if that doesn’t solve your problem.

Cheers, Todd.

1 Like

Thanks @careyh, @toddw for describing auto-update system :smile:

Update to 8.5.4 fixed the issue, thanks all.