Cannot uninstall Komodo IDE 11 from Windows 10 Enterprise


#1

Summary
Decided to move to ActiveState Platform, so necessitates removing the installed version.
Running from Add/Remove programs: The Wizard shows “Welcome to the ActiveState Komodo IDE 11.0.0 Setup Wizard”. Selecting Remove, the wizard runs for a few seconds, maybe 15, while “validating the installation”, and then bluescreen :frowning: - Stop code: SYSTEM_SERVICE_EXCEPTION.

Same result when attempting remove from Safe Mode with Network.

Specifications
Komodo IDE, version 11.1.0, build 91033, platform win32-x86.
Built on Wed May 30 10:04:55 2018.

OS Name Microsoft Windows 10 Enterprise
Version 10.0.17134 Build 17134
System Model OptiPlex 9020
System Type x64-based PC
System SKU 05A4
Processor Intel® Core™ i7-4790 CPU @ 3.60GHz, 3601 Mhz, 4 Core(s), 8 Logical Processor(s)
Installed Physical Memory (RAM) 24.0 GB


#2

Are you able to remove other programs? This sounds like a potentially broken system. I think we’d see a significantly higher report rate if this was hitting everyone.

Can you double check that you’re able to uninstall other programs?

  • Carey

#3

Yes, I have successfully uninstalled and re-installed several other programs that use the Windows MSI installer successfully, just to see if the MSI service was malfunctioning.

Ultimately I deleted the “ActiveState Komodo IDE 11” folder from “C:\Program Files (x86)” and the corresponding AppData folders. Once that was done the Uninstall cleared the Komodo IDE 11 entry from “Add/Remove Programs”, but there were still Registry entries to clean up.

Both of the Windows 10 Enterprise systems where this was installed required manual removal like this. My Windows 10 Pro at home had no problem removing the same version.


#4

Alright, thanks for getting back to me. I’m double checking the installer process on my machine. Could you perhaps try (on your Enterprise machine), an install and immediate uninstall to see if the issue comes up? I wonder if it could be related to virus scanners at the Enterprise locations. Those programs are notorious for disabling key portions of software silently and breaking things.

This deleted all your preferences and configurations. If you can recover this you should.

  • Carey

#5

Hi

I had the same problem - Windows 10 Enterprise and a Komodo uninstall that was not working. However, I did not get a BSOD - instead my computer just froze completely shortly after starting the uninstall. Tried 3 times after fresh reboots with the same result, and uninstalling another application also worked for me.

Deleting folders and then uninstalling also fixed the issue for me.

/Thomas


#6

Any chance either one of you could try another version of Komodo? The installer hasn’t changed recently other than to sign it. Trying 10 should be fine:
http://downloads.activestate.com/Komodo/releases/

Bug filed here:

  • Carey

#7

Also, question for both of you @Thomas_Lindgaard, @dactex, do you get the Permissions Dialog at all or does the uninstall process fail IMMEDIATELY?


#8

Carey,

No, I do not get the Permissions Dialog, and it does not fail immediately.

I get a small “Gathering required information” info box with a progress bar that show a tiny bit of progress just before the BSOD occurs. It takes about 5 to 10 seconds from the moment the info box appears.


#9

I have just completed the following scenario:

I performed a “delete the folder” uninstall of Komodo IDE 11.1.1. (Deleted from C:\Windows\Program Files (x86)

I installed Komodo IDE 10.2.3 and successfully removed it from the same Windows 10 Enterprise desktop. I used the following install file: Komodo-IDE-10.2.3-89902.msi.

I then had a “clean” Komodo IDE-less desktop, and installed 11.1.1.

I then attempted to uninstall 11.1.1, fully expecting a BSOD.

I got a clean uninstall of 11.1.1.

I installed 11.1.1 again.

I uninstalled 11.1.1 again. No problems.

In the next day or so I will do the same process on the -other- Windows 10 Enterprise system that is experiencing the same uninstall issue, and give you a report.

I think the Komodo 10 install and uninstall must have cleaned up whatever was corrupted about the installation subsystem with respect to Komodo IDE in the desktop.


#10

@dactex,man…Thank you! I really appreciate you doing all that! That’s likely to be very helpful.


#11

I have completed the same steps with the other Windows 10 Enterprise desktop that was also BSOD-ing on uninstall.

The results are that I now have 2 clean Komodo IDE 11.1.1 installations that I can uninstall and re-install without issues.

I highly suspect that there were corrupted Windows Registry keys associated with Komodo that were cleaned out with the version 10 install and uninstall. I hesitate to guess about how both machines got corrupted simultaneously.


#12

@dactex, thanks for that. @Thomas_Lindgaard, without doing @dactex’s workaround, could you reproduce the issue then see if you can get some Windows System logs? This article seems to have the steps to get those:

Thanks to both of you for your help.

  • Carey