Cannot open files in Komodo Edit (Linux / ElementaryOS)

Komodo is driving me nuts! I am running ElementaryOS (Ubuntu based disto).

I have a file named /home/www/test.php and I can open it with any other editor on the system, but Komodo tells me:

The file ‘/www/test.php’ does not exist. Do you want to create it?

(Please notice that /home/ is missing in the error message).

Does anyone have any ideas? I am very close to give up on Komodo and change to a paid version of PhpStorm instead.
I really started to like Komodo so I hope it is a fix that can be done here.

Thanks!

Is www a symlink by any chance?

Can you post the output of ls -ahl /home/www and ls -ahl /home/www/test.php?

As I can see - /home/www is a folder for your web-site. In most cases you can simply run chown -R <your_account_name>:www-data /home/www/ and it’s should solve the problem. But first you should follow Nathan’s tips and run commands which he asked to run and post output.

ls -ahl of /home/

nick@nick-nb:/home$ ls -ahl
total 32K
drwxr-xr-x  5 root root     4.0K Jan 27 19:55 .
drwxr-xr-x 28 root root     4.0K Jan 27 21:57 ..
drwx------  2 root root      16K Dec 21  2013 lost+found
drwxr-xr-x 46 nick nick     4.0K Jan 28 07:26 nick
drwxrwxr-x  3 nick www-data 4.0K Jan 28 07:27 www

ls -ahl of /home/www/

nick@nick-nb:/home/www$ ls -ahl
total 16K
drwxrwxr-x 3 nick www-data 4.0K Jan 28 07:27 .
drwxr-xr-x 5 root root     4.0K Jan 27 19:55 ..
drwxrwxr-x 3 nick www-data 4.0K Jan 27 20:24 minpt.net
-rwxrwxr-x 1 nick nick      558 Jan 27 17:37 test.php

If I open Komodo Edit and “Open / Fast Open” and then enter the path manually then it all works.
But if I open by doubleclicking in my file manager it does not.

What file manager do you use? And how did you set up the file association? I’ll try to reproduce the issue on my end.

I use Pantheon Files that is included in Elementary OS. I set up the file association by right clicking on a PHP file then “Open with…” and then choose Komodo Edit in “Show more applications…” (or similar).

Anyone that has any idea to why this is happening? There is no obvious reason for it to do so. Any other text editor works so it must be directly related to Komodo Edit.

Should I file a bug? If yes - where do I do that?

https://bugs.activestate.com/enter_bug.cgi?product=Komodo

Hmm I can’t get Pantheon-Files installed. @toddw can you give it a try?

I can. (I using Elementary OS too)

So…

  • Just double-click on any PHP file in my home folder - works fine.
  • Opening by Right click - Open With - Other Application - Komodo IDE 9 - works fine.
  • Opening ANY FILE in /home/www/ - same bug! (to be clarify: it’s can’t be a symlinked folder because I created it manually through terminal). So it looks like a bug with Pantheon file manager (because I can open any files from the terminal in /home/www/ folder via k <filename> (k is a symlink to the binary file of Komodo and placed in /usr/bin/)). Or maybe something with Komodo.

Could you try opening from another directory that is 2 levels deep (from root) ?

Opened /test.php (which placed in root folder as you asked) from Pantheon - works fine.
ls -ahl /test.php output: -rwxrwxrwx 1 defman webdev 0 Jan 29 21:39 test.php

No I said 2 levels deep from root, eg /foo/bar/test.php

Works fine.
ls -ahl for /foo/bar/:

drwxrwxr-x 2 defman defman 4.0K Jan 29 21:45 .
drwxrwxrwx 3 defman webdev 4.0K Jan 29 21:45 ..
-rw-rw-r-- 1 defman defman    0 Jan 29 21:45 test.php

For the Komodo devs: https://bugs.activestate.com/show_bug.cgi?id=106180

I am “glad” to see that you +Defman gets the same issue. This means it is not an “issue behind the buttons”.

I hope the Komodo team will resolve the issue at the soonest. While I am able to open the files by using the quick open, and once I have opened them once I can reopen files from last opened ones, so I will survive for now. But it’s rather annoying though :smile:

Can I make a quick fix for now to symlink /www/ to /home/www perhaps? I need to try that when I am home and in front of my Elementary box.

  1. I opened PF (Pantheon-Files)
  2. Created a folder through terminal
  3. Created a file through PF in the folder
  4. Tried to open it (got the bug)
  5. Re-opened PF and did 4 again
  6. Works fine now

Some things I do to get the bug and solve it.
Whatever, the Komodo devs probably knows how to fix it. Check out our IRC channel: #komodo and the IRC log

I tried the same thing as you proposed here (I think):

  1. Opened PF
  2. Went to /home/www/ and created a folder “test” then chown to my local user:usergroup
  3. Created a file in new folder named test.php.
  4. Doubleclicked the file. Komodo started and gave me the error message.
  5. Left Komodo open, closed the PF window.
  6. Opened another PF window and tried doubleclicking again. Same error as before.

Did I missunderstand you?