Cannot launch Komodo 12 with New MacBook M1 + Catalina

Hello, I have not been successful in launching either the latest Komodo IDE 12 or previous version 11 on my new MacBook Pro with Apple M1 and running macOS Catalina. I have followed the workaround directions (“layers.acceleration.disabled”) but still receive the non-responsive beachball at startup. What is the suggested procedure here for this configuration?

Morning @drewcsssv,

I don’t have an M1 machine handy to try anything at the moment but I’ve asked a coworker to see if Komodo works with M1 later when they get “into the office”. My “off the top of my head” guess is that you perhaps need to turn on x86 64 bit emulation (which I’ve heard it does insanely well) for Komodo. Komodo on Mac is specifically compiled for x86 instead of ARM.

Also, please make sure you followed the instructions correctly with the original workaround of setting layers.acceleration.disabled. I think the main mistakes people make are:

  • Editing the wrong installs pref file (if you have multiple versions of Komodo or Komodo Edit installed)
  • Editing the file while Komodo is running (I might get over written when Komodo restarts)

Please let me know if that’s a fruitless endeavour and I’ll see what I can figure out.

-Carey