Cannot Copy/Paste

Thank you for your reply. I am now comfortable with the IDE except on 2 configuration issues .

  1. Copy and Paste in the same document-the program seems not to support this feature.I have tried to highlight my variable names and copy them to various parts of my my code instead of typing them over and over. I could not manage to highlight and copy them.I have tried various options under Edit-Preferences but failed to solve this propblem.
  2. Text that is too faint to read-When typing my code, some text gets very bold and yet other text gets very very faint-almost unreadable.I have tried the Appearabce option under the Edit menu but I did notget the results I was looking for.I do not like black backgrounds anywhere. I prefer white background and black foreground. Help on these two issues would be greatly appreciated

Just ctrl+c and ctrl+v? I’m not sure I understand what you mean, of course copy/paste works in Komodo, it’s a very basic feature of an editor, but I suspect you mean something else?

Try a different color scheme under Preferences > Color Schemes.

In my copy of the program, copy and paste does not work-of course I understand what Crl+c and Ctrl+v mean because I have used them thousands of times. They just don’t work in my copy of the program. When I try to run the cursor over text to select it and copy it,the cursor runs over the text but the text won’t get highlighted as usual.As I said, I have tried different colour schemes but failed to get the results I was looking for.

Moved to new topic. Few questions:

  • What OS are you using?
  • Do you have any apps installed that interact with the clipboard?
  • Does copy/pasting work in Firefox?
  • Can you copy/paste from a regular text field? Eg. Preferences > Editor > Smart Editing > Auto-Abbreviations

This bug may be relevant to you: https://github.com/Komodo/KomodoEdit/issues/156

TLDR:

yes, and Webroot seems to have been the source of the problem. Upon disabling automatic silent blocking and giving Komodo access to my clipboard, pasting works perfectly in Komodo 9. Thanks for the help!

Deleted off-topic posts, please answer my questions above and check the bug report I linked in particular.

1 Like