Cannot add files to project

I’m new to Komodo Edit since it’s what’s used here (I’m used to UltraStudio). I can create and open a project, but several of the options under the “Projects” menu are disabled, and I don’t see anything about adding files or directories. What am I doing wrong?

You don’t have to add files. When you create the project, you define a base directory. Those are your files.

Like alvaro said, the location of your project is also the location of your project files. If you prefer not to have your project file in your file directory you can manually move it elsewhere and change the location of your files by opening the project and adjusting the “Project Base Directory” setting in the project properties.

If you’re talking literally about creating new files or folders, you can do this either from the toolbar or from the “File” menu.

All good points but you should still be able to “add” files to a project.

If your “add” options is grayed out that usually means the project isn’t active yet. Make sure you’ve either double clicked or right click > Open Project on the project in the Project pane to activate it.


  • Carey

Thanks everyone. They use GIT here, which I’m barely able to comprehend so far. Until I get a handle on GIT, I’ll have to wait for another day to mull this over.