Can not start local javascript debugging? (OSX)

I’m trying to start a local javascript debugging session with Chrome on OSX (with KomodoIDE 10.2.2, the latest chrome). However, it is launching the python debugger.

  • In project preferences, my options for “Debug Session Startup” do not include Javascript. Lots of other things
  • The path to the chrome executable is correctly set in the project and globally
  • the current file in the project is an html file with some javascript links

Am I doing it wrong? I’m following the directions ( and it looks very straightforward, but it doesn’t appear to even be an option.

hey @tekhedd,

How are you starting the debugging session and what indicates to you that it has started a Python debugging session?

  • Carey

That’s a good question. Maybe I’m just mistaking the .py files in the debug call stack. It definitely is giving me weird…

Oh I just retried and this time it just casually worked. (Fails to load and compile my google-hosted angular scripts, but that’s a completely different issue!)

What changed? Hmm, it looks like I didn’t have a project loaded at all. When I load my project file back up, it fails to run again. This time it thinks it’s running Node.js, which is what is now selected in Project Preferences: “Debugger listening on [::]:5858”? “SyntaxError: unexpected token <”?

Yup, if I change it to “Perl”, I get “bareword found where operator expected”, a classic perl error.

The thing is, “Javscript” isn’t an option in Project Preferences? How can I tell Komodo that my project is a web page with javascript? Surely this is a problem with the device attached to the mouse and keyboard: I’m just missing some extremely simple thing. :slight_smile:

Ahhh nice digging! That’s a bug unfortunately :frowning: You’ll have to delete your project file and recreated it and not set that pref.

…Unless you want to get hack on it then you can delete or try setting these prefs to JavaScript in your project file:

<string id="currentInvocationLanguage">Node.js</string>
<string id="language">Node.js</string>

I filed a bug for not being able to set the language to JavaScript:

  • Carey

Thanks, hacking got it working. : ) Much appreciated.

Nice work @tekhedd. Glad I could help.