Can I prevent horizontal scrolling?

Hi, I’ve just started learning HTML and I pretty much don’t know anything about anything.

I’m wondering if it’s possible to change it so that Komodo jumps down to a new line instead of continuing outside the window when I’m writing long lines of text.

I understand that it’s on purpose and that some might advice me to instead get used to this, but for now I would prefer to never have to scroll horizontally.


Yes. Preferences - Editor - Smart Editing, see Wrap long lines by setting.
If you don’t see Smart Editing item in Preferences, check Show Advanced checkbox in left bottom of the preferences window.

Yes that’s it, thanks! :slight_smile:

I see another problem now. I’m working with pre-made .html exercise files and it seems this setting only works when I create a new file, and NOT when I’m opening one of these exerciser files. The exercise files still open up with long lines of text that continue outside the window.
(and if I continue to write something at the end of those, the window gets even bigger and bigger)

Do you know if I can prevent this too?

You should re-open them or press Ctrl+9 or check View - Word Wrap.

Yes there we go!

How does Word Wrap differ from that other wrap setting?

There’s no difference. You can change how word wrap works in Preferences and enable or disable it temporary/permanently via View - Word Wrap

Okay, thank you for the help! :blush:

Note, View > Word Wrap only acts on the current buffer, if you want to change this for all files you need to change the pref under Prefs > Editor > Smart Editing > Wrap ..

1 Like