Calltip bug

When i trying call tooltip firstly by Ctrl+J, i get a error “no preceding trigger point within range of current selection”, but if i call tooltip later, it’s work normal. Why it’s happens?

You’re trying to call the tooltip when there is nothing relevant for the tooltip to act on (ie. it has no contextual information to give you). If you think this is a bug please provide a code sample with your cursor position so we can try to reproduce the issue.

Okay. It’s a code:

function test() { return preg_replace_callback(|<-cursor"#[a-z]+#isu","callbackfunc","bugs everywhere"); }

When i call tooltip firstly - get error. Secondary etc. - no errors, normal tooltip. I think its happens because code intelligence has no time to load tooltip firstly…

I’m not able to reproduce your issue using the example given. Have you tried reproducing it using ONLY that code (ie. in a clean file), though still prefix it with a <?php.



function test() { 
    return preg_replace_callback("#[a-z]+#isu","callbackfunc","bugs everywhere");

Yes, i tried. Tooltip shows only after second calling.
Well, thig bug was disappeared by 50%. Sometimes tooltip shows after first calling ,sometimes - after second calling. I think at now it caused by my slow PC :smile:

Can you explain what you mean by “second calling”?

Perhaps it would be useful if you explained your entire process in reproducing this bug, as I’m not sure if I understand correctly what your issue is.

But anyway, i explain.

e.g. i try to call tooltip here:


function test() { 
    return preg_replace_callback(| <- cursor"#[a-z]+#isu","callbackfunc","bugs everywhere");

Sometimes tooltip shows after one pressing shortcut (one Ctrl+J), sometimes - after two pressing shortcut and time between first and seconds calls does not play a big difference (two Ctrl+J (e.g. (Ctrl+J)+(Ctrl+J)).
If you need, i can make a screencast, but only tomorrow by Moscow Time.

Ctrl+J is both position and time-sensitive - as it has a three second window in which it will try to move to the preceding completion/calltip, so for this code:

  parseInt(Math.max(1, | ))

a second Ctrl+J will show the calltip for the parseInt method and a third call will tell you it cannot find a preceding completion.

I wonder if this impacts on what your experiencing?

I’m just made a screencast…

I made a screencast. Sorry for my English and emphasis :smile:

Wow. Two/three months later and no follow-up from the Komodo guys.

I am afraid this does not give me much faith that my question elsewhere will be answered, or if it is, be satisfactorily resolved…

Is Activestate run entirely by tech-types only who don’t understand business and taking care of customers? Just asking.

There are no any news cuz I’m fix this bug myself. It’s not a Komodo bug, it’s caused by me only. I’m forgot to say “Fixed” :smiley:

That seems a bit unjustified, we were answering all of @Defman’s questions, it happens that we loose track of a topic from time to time, at which point you can just send us a little nudge.

@Defman would you mind explaining how you resolved your issue? In case anyone else lands on this thread in the future.

I’m go reinstall my Komodo and change OS to Linux :wink:

You’re saying you fixed your problem by switching to another platform? Then how can you tell if the problem was on your end?

I’m joke, haha.
I’m clear my code intelligence folder and this fix a problem :smile: