Bug: v11 Autocompletion

Hi guys,

First: Tried several times to submit a bug on Github, but the “Submit new Issue” Button was always disabled, no matter what or how much information i wrote in the issue window. Don’t know why. So you will have to resubmit the problem on yor own.

The problem:

There is a problem in inserting newlines in a in a nested .scss file. If you want to enter i.e. 5 newlines between some nested classes, autocompletion shows up automatically which makes absolutely no sense in this situation. There is actually no way in inserting newlines without activating the autocompletion. Havent tried this in other file types but i’ll think thats your part. Here is what’s happening:

I had many other situatiuons where autocompletion shows up in no meaningful manner, destroying peaces of code - and when typing fast you can easily oversee the problems, resulting in unfunctional code. I can not reconstruct the exact situations cause it happens randomly but i’m annoyed of that behaviour because it hinders me in efficient and fast writing code. This has to be tested more thoroughly.

@petewulf I know this behaviour is different then in Komodo 10, but it is is showing the auto completion correct. In Komodo 11 the auto completion is showing when it can show an auto completion, where in Komodo X you had to type a few letters before the auto completion shows.

In you’re situation it is showing the auto completions correct, as on that position it can auto complete for classes/ids/css attributes, so it does.

I have to agree that the handling when you press Enter can be improved.
There are situations where you want to insert the selected value, but sometimes you just want to insert a line break. Know in you’re situation you will have to use the Esc key to cancel the a auto completions, so you can add the line breaks.

The question is, if this is the wanted behaviour.
I can also imagine that it would be possible to populate the auto completion with a “empty” value.
So that you would press enter with the auto completion open, you will match the empty value first.
Allowing you to add line breaks with auto completion open.


In my optinion it makes no sense to open the autocompletion if you press enter. it will begin with 99.99% unneeded options, like “-moz-appearance, etc”. Whats the purpose in opening the autocompletion if you havent typed a single char?

The autocompletion only makes sense if i’ll type a char and it makes suggestions - and thats also the behavoiur i expect. There is nothing to complete when just entering a line-break. So all you have to to is tell the autocompleter to show up on the first entered char.

Theres one thing more i’ll just encountered: When typing in PHP and clicking on a suggested variable, the autocompletion always enters the variable without the dollar sign. It also replaces my prevously typed $ so i have to add it every single time again.

Hi, the PHP issue is being tracked: https://github.com/Komodo/KomodoEdit/issues/3003

@petewulf, Agreed that this doesn’t make sense. This is a bug. Could you report the issue and include sample code to reproduce the issue you’re seeing?

You can report issues in our Edit repo since it’s a public repo:

  • Carey

Another anoying bug … related to autocompletion:
While writing a comment-block (e.g. for a method), the handy dropdown-box does not appear, when typing @… eg. @param or @returns etc.
Also while typing the @param - entry, the given variable names from the function-definition does not show up anymore.

It’s not a “harmful” bug, or “needed” feature, but it was a handy feature … until it disapeared in Ver.11


@Maik_Nolte please file a bug/enhancement on our tracker: https://github.com/Komodo/KomodoEdit/issues/new

@Maik_Nolte, I’ve reported this already. Thanks for letting us know though:

1 Like

Thanks! :slight_smile:

@petewulf does @mitchell’s link work for you? ie. https://github.com/Komodo/KomodoEdit/issues/new

@nathanr Yes, thanks, this link works
@mitchell I will create a report the next days when i’m not so busy