Breakpoints not respected after upgrading from 7 to 9

I’m a frustrated Komodo user giving 9 a shot because I paid for it :slight_smile: Starting with v6, every upgrade has been a big hassle. Always something wrong.

With 9, my breakpoints are no longer working.

I’ve been using xdebug/Komodo forever, so I can tell you it is set up properly. The Komodo debugger runs. It will stop at the ‘first line of execution’ if I turn on that option. But none of my breakpoints are respected. It just blows on through the rest of the code.

I cleared all the breakpoints inherited by the upgrade and reset them. That didn’t work either. I confirmed my URI mappings. They were properly inherited. The only thing I know is not set right is the xdebug.idekey value. There appears to be no way to set it in Komodo now, but it looks like it’s not needed as the debugger is running.

Other, unrelated annoyances with 9: You hide the menus by default and you reset my colorscheme. Boo!

Hi @hlslaughter,

I know you confirmed your URI mappings but could you try removing them and recreating them? (maybe that’s what you did. I don’t know what confirming means to you).

Menus can be shown by default through View menu > Toolbars > Show menubar.

Color Schemes: Yes, this backfired. Other users are upset about that as well (rightly so). We made the mistake of assuming people always customized their color scheme. If you did or you changed from the default at all, you should not have been effected. Can you confirm that you were using the default color scheme in Komodo 8?

If you were using the default in Komodo 8, you can get it back with the ko8 color scheme set resource (you don’t have to manually mimic it).

Just unzip the file then drag and drop the default.ksf file on Komodo.

  • Carey

The mapping must be working because the debugger starts and breaks on the first execution point. But it does not stop on any of my breakpoints.

See demo:

When I switch back to 7, the breakpoints are acknowledged.

The fact that the debugger stops at the first line of code is not related to mapped URIs at all.

It’s not clear to me if you tried my suggested steps of removing the Mapped URIs. One thing I didn’t mention is that when you remove the existing Mapped URIs, you just need to trigger a debug session and Komodo should ask you to remap.

Please give that a try and let me know what happens.

  • Carey

Breakpoints do not work locally on Komodo 9 / Perl on Linux and MacOS. You can break in the main program, but cannot set a breakpoint in the perl modules. I’ve tried modifying the environment to include the path to the modules and also tried “use lib”. Also, in Komodo 8.5, setting a breakpoint is as easy as clicking on the line (to the right of the line numbers). In Komodo 9, it pops up a dialog. Are breakpoints partially broken in Komodo 9? Or am i doing something wrong?

Hi there, could you reference this thread and see if that addresses your issue?