Breakpoints do not work


#1

I’ve used the Komodo IDE for many years. I’m moving some old Python 2.4 applications over to Windows 10. I cannot seem to get the breakpoints to work. I was using Komodo IDE 10.2.3 and when that didn’t work I installed the Komodo IDE 12 version. Still no luck. I can single step through the program but as soon as I hit the continue button, it executes the rest of the program ignoring all breakpoints.

I’m using python 2.4.4 for my interpreter. Unfortunately, I can’t update the applications to a newer version of Python because some of the required libraries are not available .

Does anyone know of a reason why the breakpoints are not working on any version of Komodo on Windows 10?


#2

@jgold, did you try Help > Troubleshooting > Restart in Safe-mode and reproducing the issue? This often has to do with your Edit menu > Preferences > Mapped URIs. If you have those configure for your project in correctly it will prevent breakpoints from working.

  • Carey

#3

Hi careyh,

Thanks for the response. I got around the problem by installing Komodo version 6. When I get a chance though I’ll try your suggestion because I’d rather have the current version.

Joe.

You can close this topic.


#4

Please report back when you’ve tried the fix :slight_smile: This is for the communities benefit too, not just a conversation between yourself and me.

  • Carey