Bookmarks not Saving

Quick bookmarks are not saved. Regular bookmarks are also not saved in my installation.

Komodo IDE 11.0.2 on Windows 10

Hi @rholland,

I’ve moved your comment to a new thread as it’s a new topic. Please provide more information. Helpful info would be the steps you’ve taken and what you expect Komodo to do.

I will elaborate when I get a few minutes

Resurrecting a zombie thread as I find myself battling this today.
I’m using Komodo IDE on openSUSE Tumbleweed (Komodo IDE, version 12.0.1, build 91869, platform linux-x86_64), and in the last few days have noticed bookmarks (regular bookmarks as in Navigation>Toggle Bookmark) not being saved.
I can’t say exactly when it stopped working, but I’ve tried ensuring the project is active, manually saving the project before closing etc, and nothing seems to work.

Any suggestions at all?

Hi @agt

What do you mean by “not saved”? They don’t activate at all? They don’t stick between file closes?

Hi @careyh, sorry for the delay in replying.
To confirm for you: the bookmarks activate while I am working on the file, and I can use F2/Shift-F2 to bounce between a handful within the file I’m working on.
If I exit Komodo, any bookmarks that were in any files are absent when I re-open. The same goes if I close, then re-open the file without closing Komodo.

Two additional data points that may or may not help:

I tried a fully reset profile
I renamed my ~/.komodoide folder and started from scratch, in case it was a setting that I had borked in error. The issue remains in the new profile.

I have an instance of Komodo Edit 12.0.0 Build 18431, that still works as expected
I’d fully switched over to IDE, but fired this up to test.
As I had recalled, bookmarks made in a file are retained between application restarts, and through file open/close.

Hope this helps!

Thanks for getting me some clarity @agt. Looks like this broken between Komodo 10 and 11. That was quite a while ago so I can’t remember what might have changed to effect this but I do recall we updated Scintilla (the underlying open source text editor library) around then and I seem to recall bookmarks coming up.

I’ve created a ticket for it:

One note for the original post, Quick Bookmarks never persisted through a file close I don’t think. At least they don’t in 10 and I believe that was the version they were released in.

  • Carey

Thanks Carey.
I don’t know if it will be any help, but I should be clear about the platform versions involved as you’re considering it may have gone missing in 10→11:
For me it had worked (that is retained bookmarks across file and application closes) in EDIT at least since version 8.0.2, and up to and including 12.0.0, and is still working.
I’ve only been using IDE since 12, and as far as I can recall it was saving “Regular” bookmarks as expected up until what feels like just a few weeks ago (although 2020 seems to have messed with the fabric of time in so many ways).

I don’t know if that helps narrow it down at all, but good luck and thanks again!

Hey @agt,

Thank you! That is indeed very helpful. I’ll update the ticket. Thanks again!

  • Carey

My guess would be that you maybe started Komodo Edit without realizing it? Bookmarks aren’t working at all for me in 11 or 12 IDE and they worked in 10. That was tested yesterday and double checked today.

Having said that, if you notice that it starts working for you please do lets us know here!

Oh I just saw that you had previously mentioned that Edit worked for you and I ignored it. Apologies for that! One thing you might try and I’ll try as well is to also rename/[remove] your *~/.komodoedit * folder as Komodo IDE will also look for Edit profiles and import them. The best way to check a fresh profile is to use Help menu > Troubleshooting > Restart in Safe-Mode.

  • Carey