Autocomplete and xemmet

Seems like a bug;

I’m on Komodo IDE 11.0.2.

I use “autocomplete” and xemmet

The key to expand a xemmet abbreviation is tab, and it cannot be changed.

So, when expanding an abbreviation with tab, we get annoying results, like this :

In css, “m” becomes this : “margin: marks: ;”

“c” becomes “color: cue: ;”

“p” becomes “padding: page: ;”

Is this a known bug ?

If could have fixed that by only changing the default for expanding the xemmet abbreviation.

Sounds like a bug in the Xemmet extension to me. Contact the developer of the extension:

  • Carey

I’ll have a look.

Hm, I haven’t this problem in Komodo X.

Maybe because you haven’t installed the xemmet package.

With xemmet, when you hit tab after “c” below, you don’t get “color: cue: ;” ?

color: cue: ;






I think the new code completion popup is unpreventable, unlike the old one. I’ll try to find a workaround.

MaxA, does “auto-completion” is enabled to you ? Edit - Preferences - Code Intelligence - Enable Completions.

With that checked, go into a css file and press “c”.
You will see a menu with “col” auto-selected.

Pressing tab after “c” will expand both the emmet code and the komodo code. Type komodo code will be placed inside the xemmet placeholder for the css value.
So “color: col;” instead of “color: #000”.

To prevent the komodo auto-completion, we have to hit “escape” (to exit the auto-completion menu) before doing “tab” (to exapnd the correct emmet code).

The autocomplete is preventable when hitting “escape” to escape the autocompletion menu.

But it’s annoying to always have to hit escape. Should I open a bug for this on github ?


Typing “col”. Hit escape. Hit tab. Result : columns: ;

If no escape, result : columns: colgroup;

Well you can open a bug but I’m unsure at this moment how I could fix that.

Another issue :

Inside JSX file. I expand a komodo snippet that includes tabstops.

On the first tabstop, I write “input”, then hitting “tab” just goes to the second tabstop, instead of expanding the “input” tag.

As I said, the “xemmet” shortcut should really be changed. Cause “tab” interferes with Komodo’s tab behavior,

I’ve got a full time job so I don’t have any time to fix the issue.