It’s the first time I’m trying Komodo IDE 8.5.4 and I don’t understand how auto-completion works. I’m writing in Python3/PyQt5. Python3 is the only Python version installed on my system (Windows 8.1 64-bit). Auto-completion works fine on every other editor I’ve tried, just by hitting the tab key.

For example, in Komodo I have to type the whole word “print”. No suggestions while I’m typing it. If I type “print(” I get a nice calltip. If I start typing “import” it works, but if I type “from os.path import expanduser” it doesn’t autocomplete “import” (but it does autocomplete os, path, and expanduser). If I try something like “from PyQt5.QtWidgets import QApplication”, it only autocompletes “from” and “PyQt5”. Auto-complete fill-up characters are enabled. Pressing Ctrl+j makes no difference, and hitting tab just inserts spaces.

Is this how it’s supposed to work in Komodo, or is there something I can change in the settings? Thanks in advance!

It works best when your create a project and add specify the languages used. You can then add the directories those language files are located in from within the project settings which Komodo will then index.

1 Like

Thanks for your reply. I tried various things like, adding the Python installation dir, the site-packages dir, the PyQt dir. I have also installed Python extensions for Windows (since I saw it’s listed as an option in the preferences). All this made absolutely no difference. Same thing on the Mac.