Auto complete with HTML


#1

There seems to be an odd thing happening with Komodo IDE 12.0.1 and the auto complete is making things very frustrating to work with. I just recently upgraded from IDE 11.xxx to the current version, and the old version never had this issue…

I have HTML code that looks like:

<nav id="hdr_nav">
     <ul>
          <li></li>
     </ul>
</nav>

Now whenever i try to add a CSS class to the <ul> start tag, i put the pointer after the ul and before >, then press spacebar. Instead of being able to add params to the ul tag like i wanted it instead injects new HTML, over and over again. The only way around this is to put to cursor back to typing position in UL tag, type some gibberish (say ‘abc’) so the ul tag looks like <ulabc> and then i can add the space I need, then having to erase the added ‘abc’ to return the tag to the original. NOW i can finally add params to the tag!

Picture shows how tags are added for auto complete which is not the right step to take. Is there an easy way to stop this spacebar auto complete thing? I also confirmed this behaviour happens when you hit ; instead of spacebar (same procedure as above to replicate)

Thanks for any help


#2

@ryak,

This is Auto-Abbreviations from the Toolbox. You can disable triggering them on spaces in your preferences; Edit menu (Komodo on mac) > Preferences > Editor > Smart Editing: Auto-Abbreviations, remove the space from the list of trigger characters.

  • Carey