After update Komodo IDE (10 -> 11) section list doesn't work

After update some key bindindings was lost.
And even when set up key for section list again - it still not working (navigation on sections doesn’t work too).
File types IDE recognize correctly, but the item “section list” in the menu is not active:
What I need to do?

Seems I forgot to update this menu entry, bug logged here:

As for the Section List itself, this still exists in your statusbar. Just click on the symbol name that appears when you are editing a file. From your screenshots this appears to be the 3 little dots in your statusbar as your window is too small to show everything.

Section List is absent in the statusbar. When I click on “Select Symbol” nothing happens.
In this place (Select Symbol) nothing appears when I edit the file.
Komodo IDE doesn’t work with Section List at all. IDE doesn’t see the sections, so can’t jump to next/previous section.

Could you create a simple javascript file with the following contents:

function foo () {


Then check if it’s showing any symbols in the symbol list?

Also, please share your error log. Help > Troubleshooting > View Log File

For JS Symbol List works. But for perl doesn’t (only in v.11, version 10 - all right):
log file:

Also syntax checking doesn’t work for perl (not background, not when press key “Run Syntax Check”)

Could you share some Perl sample code that reproduces the issue for you?

Also, can you reproduce the issue under Help > Troubleshooting > Restart in Safe-mode?

Note I tried to reproduce the code in your screenshot but am not getting any issues on my end. Might also be worth for you to try our latest nightly:

Yes, with latest nightly Symbol List works! But “Show Section List” still not working, expect a fix.

That will be fixed here -