Abbrevation indentation context not maintained


#1

If I expand a komodo abbreviation, and I’m not at the beginning of the line, the abbrevation indentation context is maintained.
In the abbreviation properties, “Maintain indentation context after insertion” is checked.

It was working before.

Typing “if” in the middle of a line, then expand the abbreviation :

               if (test) {
	//code
}

It should be this :

               if (test) {
	             //code
               }

#2

Tested it, but you’re correct also this is broken.
Reported the issue:


#3

Excellent! thank you !


#4

In some cases I don’t have this issue, but I don’t see why.

For the same snippet, in 2 php files, I have different behavior : Only in one file the indentation context is kept. In the other php file, I have to tab the lines to correct the indentation.

What could be the problem with the file where’s it’s not working ?

It is working on a file not created by me.
On a new file, I have this problem.


#5

OH!! I’m on Windows 10.

If I change the file’s “Line endings” setting to “UNIX” (using Notepad2), then the indentation context is kept.

So, until it’s resolve, I’m changing this komodo preference :
“File Opening”, “Sepectify the end-of-line (EOL) indicator for newly created files.”,
from “DOS/Windows (\r\n)”, to “UNIX (\n)”.

Now my snippets keep the indentation context.


#6

@trogne, that’s really helpful info to add to the ticket that @babobski filed. I’ve added it but next time please add your findings to the issue tracker.

  • Carey