Zend project debugging setup

I want to debug my zend project which is in my local web server using Komodo IDE 10. I’m under Ubuntu 12.04 platform. I’ve both web server(bitnami-lampstack) and komodo in same system. If I debug this project, it should be called as local debugging or remote debugging?

I’ve php.ini file in 2 locations.
2.File system

which one i need to use. Even if i use the php.ini of my web server, Komodo uses only my local file system’s php.ini. So there is some conflict in debugging.
If I debug javascript file it automatically launches browser window. If i debug a php file, browser is not launched.

In the setup documentation its given like we should use xdebug.so file specific to the komodo ide. Where i should place it?

I am not familiar with PHP debugging, so I can only answer your first question: you would be doing remote debugging with PHP if you expect to load a page in a web browser and have Komodo start debugging it. (You would not be pressing “play” or use the Debug > Go/Continue menu option.)

We have instructions on debugging PHP with Komodo that may be helpful: http://docs.komodoide.com/Manual/debugphp

The local php.ini is for local debugging, the remote php.ini (the one your web server uses) is for remote debugging.

Basically you’ll want to point Komodo itself at your local php.ini, and ensure that your remote php.ini is configured for debugging as per our documentation.

If you’re only doing remote php debugging (likely you are) then configuring your local php.ini isn’t even necessary, but still recommended.

Thanks for your quick replies, Finally it was fixed. I used my local web server’s php-cgi (server-path/php/bin/php-cgi) for php interpreter. It should be given in the Edit->Preferences->Languages->PHP.
Then in the Debug menu I selected ‘Listen for debugging connections’. after this ‘Debugger Listener’ will generate a random port number in the ‘Host Port’ field if the system-provided free port is enabled. If you want a specific port need to update it in Edit->Preferences->Debug->Connection. This port number should be given in the xdebug configuration of php.ini(local webserver) and in the Environment variable SERVER_PORT. Now if we run the particular url in browser suffixed with ?XDEBUG_SESSION_START=1 the execution stop at the given breakpoint

Hope this will help someone

1 Like