Scrolling problem

Hi, I just switched to Komodo Edit and I am not sure what is happening.
When I write my code, everything seems fine, until my content is bigger than my screen and vertical scrollbar appears. When I write something at the bottom lines of the file, editor scrolls up and I cannot see what I am typing. Scrolling back manually does not help, it jumps up again when I start typing.

I run it under Windows 8.1, 64bit.

That’s odd, not a bug I’ve seen before. Do you have any uncommon peripherals and/or software that might be interfering?

As a potential workaround you could try increasing the Minimum number of lines to keep above and below the cursor setting, which you can find under Prefs > Editor.

Do you have the editor minimap enabled? If so, try disabling it using View > View Minimap to see if that makes a difference.

Thank you for your quick answers,
I tried your solutions with no success, but I just found out what is the problem. I latter noticed that the problem only occurs after I write some keyword or something that the editor knows and suggests. The problem is that the suggestion box appears at wrong locations due to wrong DPI scaling. So the problem is with the stupid Windows 8.1 I’m running. Editor was all blurry because of Windows 8.1’s DPI scaling so I had to disable automatic DPI changing to make it render sharp. When I enable DPI scaling, the problem with scrolling is gone, but it is all blurry again.

DPI scaling off, sharp rendering, scrolling problem -
DPI scaling on, blurry render, everything else OK -

I know that my problem is more about windows than Komodo Edit now and I’m still trying to google some workarounds, but please let me know if there’s some way through this I’m missing.
Thanks in advance.

I’m having the same problem. I’m running Komodo Edit 8.5.3 on Windows 8.1. When typing code into the editor and you are near the end of the file and when the autocomplete window pops up, the code in the editor jumps up and you can’t see what you are typing until you clear the autocomplete window and scroll back down. Sometimes the autocomplete window goes off the bottom of the screen as well. I’ve tried increasing the ‘number of lines to keep above and below the cursor’ and minimap is disabled. The problem still persists. The only solution (that I have found) is to turn off autocomplete, which is a problem for me because I really like that feature. I also have Komodo Edit 7.1.3 installed on my system and I don’t encounter the problem on that version. I hope this helps and you can fix this problem soon. Thanks.

Same Problem with Komodo 8.5.3 on Windows 7 64 bit.

Could you both try the same workarounds already suggested in this thread and let us know whether they work for you?

Already did. Said so in my post.

Could you try the latest nightly build? Available here -

I downloaded the nightly build dated June 20, 2014 and the problem is fixed. Thanks a lot.

It is working, thank you! :slight_smile:

I moved a post to a new topic: Make the scrollbar wider?

I have the same problem with Komodo 9.2 and Linux Debian

Could you open a new thread with more details (screenshot/video?) @TopSecreT? Seeing as the issue being addressed here was fixed in a nightly it is probably not the same issue, although the symptoms may overlap.