Publishing overlapping icons

Defman, yes, I just found it at the same time and that worked! So last thing is just trying to get the menu bar to show permanently and some minor theme changes to make this look good. Mostly good now.

The main other thing is the overlapping icons?

btw I think the first screenshot is a bug, so if you don’t mind please file it

Hamburger Menu - View - Toolbars - Show Menubar

Wait a second @mjbrancato, the first screenshot (with overlapping icons)… is your project under git version control? (or any other CVS control)

Yes, the project is under GIT and Project publishing, so basically double icons and it should pad to the right a little bit more.

Also, I got the color scheming fixed with something like this (for the most part this is really good): It looks so much better.

Thank you for your help. Sorry woke up to email about Komodo IDE X and got excited to install and then had a few problems and wanted to use it for my work today (kind of freaked out). So everything is good right now, just those GIT icons that aren’t padding out correctly.

And thank you about the showing the menu part. I totally forgot about the view toolbar part.

They should not be visible, Komodo X just colorizes the name of the file depends on its git status… Are you able to reproduce it with safe mode? (Help - Troubleshooting - Restart in Safe-Mode)

You’re welcome :slight_smile:

Safe mode removes the extra icon and it shows the color of the file just like you said. Maybe it’s a setting that I had previously set on the Komodo IDE 9?

Idk, could be. @nathanr?

I tried the default themes from Komodo (Komodo) and still the same thing. I don’t see any other icons that can be set. Unless if it’s a plugin, but I don’t recall installing a plugin that would do that.

It could be a problem with your settings that has been imported from 9.3 because you’re not seeing this problem with Safe-Mode (in Safe-Mode, Komodo uses a clean temporary profile).

I wonder if it’s just an old hidden setting. I tried different themes, I tried restarting with no addons, I tried clearing caches and same thing. I’d hate to have to rebuild my prefs.xml from the ground up including the formatters.

Try to search something related to git, icons, or status in your prefs.xml. Or wait for a response from the dev team :slight_smile:

maybe it’s an iconset? chrome://iconset-dark/content/manifest/chrome.manifest

Can we still change these?

I’m not sure, but icons are used in the UI a lot. Just wait for Nathan or someone else.

I would open Commando > Packages > Manage Packages > and try removing any packages that having to do with Iconset or skins. I do see that you tried Help > Troubleshooting > Restart without Addons but perhaps that didn’t work properly.

The Icons that you’re seeing don’t exist in the Komodo source any more so that is why I think it’s an addon.

  • Carey

I don’t see it as an addon:

I even tried removing that string element out of the prefs and still the same thing.

Renaming prefs.xml does the same thing as well.

Creating new files in GIT do this. Can’t even see the filenames.

I’d try removing any of those addons you have installed that have an x (not compatible) beside them. I know SITES is broken and needs updating. That’s been reported by the creator of the addon.

Just want to clarify that you moved prefs.xml and prefs.xmlc out of the way while Komodo was shutdown. Upon restart you still saw the issue?

  • Carey

I removed all plugins except TODO plugin. Still the same issue. I removed prefs.xml and prefs.xmlc no issue because it deletes all the settings for publishing. So I will have to reset this up.

I get the same issue when removing prefs.xml and prefs.xmlc. Could it be because publishing is being used? Whenever I set publishing up it does this.