Poor performance on Windows 10

I’ve got Komodo Edit 10 on Windows 10 and I’m seeing inconsistent response times to my keystrokes and mouse movements.

Komodo Edit, version 10.0.1, build 17276, platform win32-x86. Built on Wed Jun 15 08:36:15 2016.

In fact just copying that build information out of the help screen took 3 seconds for the mouse/keyboard to respond. This happens a lot while typing, too. I’m just curious if others are experiencing this.

Do you experience the same performance problems when you restart in safe mode? (Help > Troubleshooting > Restart in Safe Mode). It’s possible an add-on from a previous version of Komodo is causing some problems.

I will try that. Out of curiousity I opened Windows Task Manager. I can see Komodo using 788 M of memory. That sounds way too high. I wonder if that’s causing the issue.

Yes, that seems overly high. Are you working with particularly large files? Or do you have a large number of files open? Perhaps there’s an errant add-on causing trouble (safe-mode would temporarily prevent that). Let us know if this happens again and what the circumstances are. Then we can help diagnose the problem.

I’m not doing anything weird that I can think of. Safe mode seems to be fine and what I would expect. I have been running safe mode for 2 days now and memory consumption is around 241 M. Still seems a bit high. In fact yesterday it was about 142 M and it seems to have grown. I will continue in safe mode for another day or two. Performance seems to be exactly what I would expect though.

To my knowledge I don’t have any add-ons installed but what should I check to make sure? Or anything else I will check that, too.


Tools > Addons should show you the packages you have installed. Is that right @careyh? Plugins and add-ons from previous versions of Komodo should show up there, right?

@mitchell, yep! That displays all installed addons, whether they are outdated or not.

  • Carey

I think it could be better to take a memory snapshot so someone (me for example) could analyze what’s causing the memory leak. (Help - Troubleshooting - Memory Usage):

Since it’s json, we can simply sort it from the highest to the lowest by memory usage.

Defman where would you like me to send the analysis file?

Up to 325 M today. I’ll leave it going over the weekend, too. Also I checked and I have no add-ons installed.

I’d prefer to see your “broken” profile report which is using about 780MB of memory:

You can upload it anywhere, Dropbox for example.

Defman, I closed the instance that was using 788 M. The instance I have now is running in safe mode that I started last week. It’s using 343 M now and has been running for about 5 days. Would you like me to let it go longer before I give you the memory analysis? Or would you like me to restart outside of safe mode and see how high the memory usage gets again?

Restart outside safe mode and if it’s using too much memory (~700MB) - try to make a memory snapshot.
Note once you’ll close your safe mode instance, any changes made to the safe “profile” will be removed.

Ok guys, I restarted and I have the memory usage up to about 420 MB. I’ve uploaded the memory analysis to google drive. Let me know if you can’t reach it.


I downloaded it. Once I’ll find some bad things, I report back there.

Breadcrumbs uses a lot (65MB), other add-ons uses 1.33MB in total:

The DOM itself and its styles uses about 120MB:

JS Runtime (=Komodo functionality) uses about 259MB:

There’s a prompt dialog that uses 33MB:

The rest seems fine to me. I’m a bit surprised about breadcrumbs, it uses too much for itself. However, I’m not an expert at analyzing logs.

@Defman, that does seem like a lot for breadcrumbs but mines sitting at 40MB. I’m guessing if you look at yours you’ll see a similar number. Overall, that is not an odd memory footprint for Komodo. It’s a huge program. Mine will fluctuate between 200 and 600MB. Maybe more sometimes. Besides, unless it’s using ALL you’re memory then that shouldn’t be whats effecting the process.

@Meatwad, did you try @mitchell’s first suggestion?

  • Carey

Mines using 0.22MB :stuck_out_tongue:
My add-ons are using 9MB in total.

Agree, Komodo IDE is a massive thing. But the op uses Komodo Edit, which should be much “lighter”, I think.


@careyh, yes I did. In fact memory was growing inside of safe mode and it crashed before I could take a memory analysis. I can’t speak for the memory consumption since I’m obviously not the designer but that seems excessive to me which is why I brought it up. If you feel that’s ok then maybe it’s ok.

The real issue is still remaining though. Performance is very sluggish and the autocomplete features, such as matching a curly closing brace when I type an opening, aren’t working. It appears to be because I am typing faster than Komodo can autocomplete. I’m not fast, BTW.

That’s fair but I’d challenge you to find an IDE that doesn’t have a similar footprint. It’s not a Editor remember so don’t compare it to Sublime or Atom or something like that.

Ok, start disabling features then and testing results. In preferences:

  • Turn off Code Intelligence
  • Turn off syntax checking
  • Disable Source Code Control for the tool you may be using
  • Editor > Confirmation Dialogs: Disable Detect when files are changed

Wait…after reading your response it’s not clear to me that the slow typing continued in Safe Mode. Is that the case?

  • Carey