Permission and start issues for Komodo Edit 9 on Linux

hi,

i am trying to run Komodo Edit 9 on Ubuntu 14.04 LTS and after successfully installing i can’t make it run. i have read this post Komodo Installation not working in Ubuntu and tried most of the stuff suggested in there but to no avail. i came to a conclusion that i am also having permission issues.

my log file has a lot of warnings and a single error entry:

[2016-04-11 17:25:55,452] [ERROR] codeintel.komodo.js: 
-- EXCEPTION START --
TypeError: this.view is null
+ stack
    this.CompletionUIHandler.prototype._setAutoCompleteInfo@chrome://komodo/content/codeintel/codeintel.js:729:17
    this.CompletionUIHandler.prototype.setAutoCompleteInfo/<@chrome://komodo/content/codeintel/codeintel.js:1064:34
-- EXCEPTION END --

trying to sudo execute Komodo gives me this:

ng414@mdpc244:~$ sudo Komodo-Edit-9/bin/komodo
sudo: unable to execute Komodo-Edit-9/bin/komodo: Permission denied

trying to change permissions on the bin file gives the same error:

ng414@mdpc244:~$ sudo chmod 755 -R Komodo-Edit-9/bin
chmod: cannot access ‘Komodo-Edit-9/bin’: Permission denied

any help would be greatly appreciated…

sudo chown $USER:$USER -R ~/.komodoedit/
sudo chown $USER:$USER -R ~/Komodo-Edit-9/
sudo chmod 755 -R ~/Komodo-Edit-9/
sudo chmod 755 -R ~/.komodoedit/

You must not run Komodo as sudo because it chmod your profile directory to root. And I think you shouldn’t run Komodo installation as sudo as well.

hi Defman,

i get this message for the first two commands you suggest:

chown: invalid group: ‘ng414:ng414’

Your distro doesnt use your username for the group name, the correct commands are:

sudo chown $USER:`id -g -n $USER` -R ~/.komodoedit/
sudo chown $USER:`id -g -n $USER` -R ~/Komodo-Edit-9/

@Defman don’t chmod, this is an ownership issue not a permission issue.

i am still denied permission…

Could you try removing your install folder and your profile folder (make a backup of this one to be safe), then reinstalling Komodo and ensuring that you launch it as a regular user (not sudo, not root).

Your profile folder is located at ~/.komodoedit

what’s the name of the profile folder? the only thing that lives inside ~/.komodoedit is the 9.3 folder, which in turn doesn’t contain anything that automatically strikes me as my profile folder. apologies for dumb questions – i am really new to linux.

secondly, does it matter if i download Komodo from the website and unpack and build it or install from the repository using command line (like here http://askubuntu.com/questions/172814/how-do-i-install-komodo-edit)?

You should delete (and backup) all of ~/.komodoedit

It’s better to download Komodo Edit from the web-site and not using a PPA (because it’s an unofficial PPA)

okay, so it seems to be working now, thank you both. however, i remember last time it opened once initially and then, after being closed, refused to start again. hopefully this won’t happen again this time. i closed and opened it a couple of times and it was fine.

i got this warning message during the installation:

install: warning: It appears that either your system does not have gtk-2.0 installed, or your system's version of gtk-2.0 is not up to date.
Komodo requires version 2.24 or greater. Please update gtk-2.0. While Komodo will still install correctly, it may not run.
This diagnostic is not fool-proof. If you are sure the package is installed and up to date, you may safely ignore this warning.

which i ignored because i am pretty much sure i have the right version of the gtk.

more disturbingly the first time i run it from the console i got this message:

ng414@mdpc244:~$ Komodo-Edit-9/bin/komodo

(process:7054): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
1460565655713	addons.xpi	WARN	Exception running bootstrap method install on check-compatibility@dactyl.googlecode.com: TypeError: Unknown preference type: undefined (resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/MINTS/ng414/Komodo-Edit-9/lib/mozilla/extensions/check-compatibility@dactyl.googlecode.com.xpi!/bootstrap.js:169:18) JS Stack trace: set@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/MINTS/ng414/Komodo-Edit-9/lib/mozilla/extensions/check-compatibility@bootstrap.js:169:19 < install@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/MINTS/ng414/Komodo-Edit-9/lib/mozilla/extensions/check-compatibility@bootstrap.js:56:9 < install@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/MINTS/ng414/Komodo-Edit-9/lib/mozilla/extensions/check-compatibility@bootstrap.js:212:9 < XPI_callBootstrapMethod@XPIProvider.jsm:4436:9 < addMetadata@XPIProvider.jsm:3332:1 < XPI_processFileChanges@XPIProvider.jsm:3441:23 < XPI_checkForChanges@XPIProvider.jsm:3602:34 < XPI_startup@XPIProvider.jsm:2090:25 < callProvider@AddonManager.jsm:208:12 < _startProvider@AddonManager.jsm:667:5 < AMI_startup@AddonManager.jsm:821:9 < AMP_startup@AddonManager.jsm:2399:5 < AMC_observe@addonManager.js:55:7

(process:7054): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

i am not sure how significant this is and whether it will impact Komodo on my machine in the future.

None of these errors will impact Komodo. Don’t know what’s “Glib-CRITICAL” is for, but I’m always getting it and my Komodo installations works for me for 2 years without any crashes.

That’s ok, it’s just an automatic check, it could be incorrect, if you’re sure then don’t worry about it :smiley:

hey, thanks! hopefully no problems in the future :smile:
now, onto figuring out how to make R work on Komodo.

@stasg,

Maybe this will help you: http://komodoide.com/packages/addons/sciviews-k/

Komodo already has builtin highlighting for R btw.

  • Carey

Just don’t start Komodo with sudo and you’ll be fine :slight_smile:

@careyh thank you, yes, i see now. R extension wasn’t automatically recognised but, when manually chosen, the correct highlighting was applied!
i’ve also installed sciviews-k but it claims that it can’t find my default R installation (which is obviously not true). so it seems l’ll have to fiddle with it some more to make the console work in Komodo.

@nathnar i won’t. thanks again :smile:

If it’s not working correctly make sure you reach out to the developer of the add-on. If you’re able to fix it they will likely appreciate a pull request :smile:

Here’s the repo: https://github.com/SciViews/sciviewsk

I’m stoked we got you all fixed up and running again!

-Carey

cheers, Carey!
i’ve now reported a problem i had encountered with the sciviews-k to the developers. hopefully i’ll get a response soon – Komodo seems like a really nice editor (and more) and it’ll be great to get it running with R.

1 Like