Not a fan of Find-In-Files toolbar

I love Komodo Edit and have it at work and at home. So I’m not trolling.

I AM color-blind, and maybe that’s why I have trouble with the toolbar. I don’t know if the Ignore-Case, Match-Whole-Word, Multiple-line, and regular-expression buttons are colors or just grey. Either way, I can never tell what state the Find is in. I mouse-over and with the Ignore-Case I can tell, but not with Match-Whole-Words.

So I find that I search… no results… click one of those… no results… maybe I clicked twice? Click again… No results… eventually I get it set right, and it’s good for the session.

If possible, this is a request that you either have clear icons showing the state, clear mouseover for the whole-word thing, or primary colors or text or some way to make it more clear.

Or tell me how to determine the state more easily.

Otherwise I love Find-In-Files and use it alot!

Hi @DTalley2000,

It might be helpful if you added a screenshot to show what you’re seeing. Also you didn’t mention which Komodo version you’re using. There were large UI changes in Komodo 10 which SHOULD have made these things more clear.

Here’s a gif of what I see in my UI. Note that I’m using Komodo 10 and that I’ve modified my UI colouring slightly. The orange colour to indicate the active button is a blue (still contrasting from white) by default. I changed that in Preferences > Color Scheme: Left dropdown: interface: Secondary Special.

  • Carey
1 Like

Note the gif quality makes it look as if Komodo’s background colors are off… that’s the GIF, not Komodo.

Have you tried the different color schemes? We cannot please everyone with our default colors, but we provide plenty of ways to change them to you preferences.

1 Like

The color scheme preference for the find dialog’s toggle options is called “secondary special”. Perhaps you can tweak that to a color you can see against the default background.

1 Like

Thank you! Glad I asked.

I had Komodo 9… yes 10 is a huge update, including the color editor.

I can see the icons now. Awesome. Thanks for all the feedback.