No CSS hints, autocomplete or validation in Komodo 9

Ever since upgrading Komodo I have lost CSS support. There is no hinting (and thus no auto-complete) or validation. The only relevant thing I see in the log file is RefactoringLanguageServiceBase: Can't find a refactoring service for CSS. I can post the full log file is that would be helpful. I’m on Windows 7 with 9.2. On OSX with 9.1 CSS seems fine.

Can you clarify what you mean by hinting? Things that cover the CSS specification should be auto-completed, but there is currently no CSS codeintel.

Just auto-complete then, sorry for the confusion.

Sorry, that still doesn’t answer my question. What are you expecting to be auto-completed that isn’t? Can you give an example?

CSS properties. For example if I start typing

.class-name {

I’d expect it to offer me text-align to auto-complete and then show me the properties. Also if I typed

.class-name {made-up-property: bladsger}

I’d expect the syntax checking to complain.

1 Like

Both those things work correctly for me. Have you tried creating a brand new CSS file and reproducing the issue?

It doesn’t work for me in any CSS file (I’ve tried dozens) or in a new file.

Are you using Edit or IDE? Does syntax highlighting work properly?

IDE. Syntax highlighting seems fine.

Anything in your error log? Help > Troubleshooting > View Log File.

No, nothing when I open a CSS file. There was that one item I mentioned in the original post but it doesn’t seem to have cropped up again. The log file is just full of Python/ pylint notices.

Do code completions for other languages still work?

Yes, Python works fine, HTML is working.

Maybe your installation is corrupted?

Wouldn’t that be a pretty specific corruption if the program runs just fine except for CSS auto-complete?

Sometimes this could happen. A file was not extracted properly or was corrupted during the installation process or something like that. Just try to re-install Komodo and see if you’re able to reproduce the issue because I’m not able to reproduce it :frowning:

See if starting Komodo with default settings makes a difference?

That seems to have fixed it. Thanks for sticking with me, I should have tried that earlier.