New to the komodo and cant seem run code

“The Thunderbolt” is Run Inline feature, you can select a code and run it. If you want to debug your script - Press F5 or open Alt-Menu - Debug.

Actually you don’t have to select anything. If you click it without a selection it will run the current file. It’s explicit intend is to make the Debug option redundant if you just want to quickly run some code.

@tdadmin could you share a piece of code that reproduces the problem?

Here is a simple example.

   # Generate random numbers
    number1 = random.randint(0, 9)
    number2 = random.randint(0, 9)
    # Prompt the user to enter an answer
    count =0 
    while count < 10:
        answer = eval(input("What is " + str(number1) + " + "  + str(number2) + "? "))
        count = count + 1

What language do you have selected?

I tried running it as Python (had to import random) and it seems to run fine. Although it won’t actually work since you are asking for input and “Run In-Line” is not a terminal emulator.

Do you have Python configured under Prefs > Languages > Python?

Sorry I didn’t copy import from the code. What do you mean configured? How should I configure it?

You should set Python interpreter in this tab.

I made this setting. What will this allow me to do? I just want to be able to run a script without this coming up every time I run a script.

That is something completely different. Please stick to the steps I gave you and we should be able to figure this out.

I did what was asked

And the error remains the same?

Can you share the contents of Help > Troubleshooting > View Log File after reproducing the issue?

No error but cant run script that uses input unless I run the debugger. This really makes not one bit of since to me. I have to run the debugger to type input?

If you want to pass custom input you can use “Debug > Run WIthout Debugging”, this is outside of the scope of the “Run Code In-line” feature.

How do I stop the below from coming up every time I do a run? Even if I do a “Debug > Run Without Debugging” which is F7 I still get the box. I don’t want to have to push save and then ok on this box to just run simple code. I should be able to just push “Run” and the code run’s with no interruption.

LOL this IDE has a lot of features which is cool I guess. Just a little hard to figure out. Found how to stop the window from coming up on run.

A lot of time has been and continues to be spent on improving the overall UX, that’s why there’s parts where the UX is a breeze and parts where it’s still a bit … far fetched. As it is in this case. The debugging dialog UX is definitely something I’d like to get my hands on sooner than later.

Glad you got it sorted, sorry for the inconvenience.

Because You didn’t want to write the answer I’ll do it for You:
Menu->Edit->Preferences->Debugger->Skip debugging options dialog when launching.

Let’s keep it friendly, please.

A post was split to a new topic: Running python code gives strange output