Login on start failure


#1

I’m install trial version for testing on linux x64. When app started show login window, but I could not login, because the IDE does not use the proxy system settings, and I cannot enter the settings without authorization.


#2

Hi there, sorry for the inconvenience! You can still configure a proxy but it’ll have to be slightly more involved.

Open up your XRE/prefs.js file in your profile folder. You’ll want to add entries for the preferences documented here:

So you’ll want to add something that looks like:

 pref("network.proxy.ssl", "proxy.server.local");
 pref("network.proxy.ssl_port", 8080);
 pref("network.proxy.type", 1);

You might need different options depending on what type of proxy you’re using. Refer to the link above for more info on that.

We’ll look into facilitating this better in a future update.


#3

This should auto detect proxy settings. I added it to my prefs.js file and it got me up and running.

user_pref(“network.proxy.type”, 4);