Komodo ruby debugger couldn't load ruby-debug-base component

After installing, I tried to start a simple hello world app through debugger after verifying it worked through the Ruby Command Prompt drag + drop. Here is the error:

My environment:
Windows 10
Ruby 2.1.7
Komodo IDE 9.2 (trial)

Any help on how to get debugger working with this setup?

The debugger for Ruby currently only works up to version 1.9.3, the debugging library Komodo depends on has not been updated for Ruby 2. Support for 2.x is on our roadmap but currently it is simply not supported, unfortunately.