Komodo needs Force-Quit on MacOS SSH FS

I use Komodo on OSX and Linux. The linux version is just fine. I think linus has a better SSH FS implementation.

On OSX, I frequently lose the ssh connection. OSX usually reconnects ok. (There are some times when it doesn’t, but for the most part it recovers) But when Komodo is open, and the connection goes down, Komodo just waits forever for what, I do not know. It might be rescanning files, or gets the disconnect notification. I don’t know. But I force quit it, relaunch and everything is ok again.

It would be very helpful if Komodo didn’t lock up several times a day. Again, this is OSX - Linux is rock solid.

Also, It seems that the file system gets reconnected and Komo is unaware that it’s back. I can cd/ls the remote contents while Komodo is hung.

No such issues on a local disk though.

Could you file this as a bug? https://github.com/Komodo/KomodoEdit/issues/new


I believe this is a known issue: https://github.com/Komodo/KomodoEdit/issues/70#issuecomment-87009746

See the above for a workaround but basically, you need to turn off remote file changes checking.

Edit > Preferences > Editor: Confirmation Dialogs: Disable “Detect when networked files are …”

  • Carey