Komodo IDE - sign-in problem


#1

When I want to start KomodoIDE, I am required to sign in to Active State (which I already consider odd; why can’t I use an IDE without internet access). However, entering my credentials yields “Login failed with message: Invalid login”.

Note that i can login with the same credentials on the web to the sites https://account.activestate.com/ and https://community.komodoide.com/
(I am aware that these are different accounts, but I have set up my credentials so that both have the same e-mail address and password).


#2

Hi @rovf,

You need to use the credentials used to log into platform.activestate.com. Can you confirm the credentials you’re using work there?

  • Carey

#3

AGAIN another account needed? How many different ones do you have???

No, I haven’t, but based on your suggestion, I just registered there. Worked fine, though (strangely) there was no confirmation email, as is usually the case. Anyway, I can sign in using the web browser. However, Kodomo IDE still does not work, though this time, the error message is different:


#4

Hi @rovf, needing a Platform isn’t new. That has been the case for over a year now.

This login error is a known issue and has been handled in multiple other forum threads. Use the nightly here and you should be up and running:
http://downloads.activestate.com/Komodo/nightly/komodoide/latest-12.0.x/

  • Carey

#6

This nightly build reproducibly crashes my system! I downloaded http://downloads.activestate.com/Komodo/nightly/komodoide/latest-12.0.x/Komodo-IDE-12.0.1-91852.msi and started the installation. When it comes to selecting the location for the program to be installed to, as soon as I click on OK, Windows complains that the application becomes unresponsive, and after 1 or 2 minutes (estimated), I get a bluescreen.


#7

@rovf, sounds like the installer might be corrupted from the download or maybe from an antivirus running on your computer. The installer is working fine for other users. Try downloading and running it again.

  • Carey

#8

The MD5 sum of the downloaded Komodo-IDE-12.0.1-91852.msi is

979881b097f30339512af852f9102edd

Could you verify, whether this is correct?

As for Virus checkers, we have McAffee running. Also I have the G Data USB Keyboard Guard active and I am behind a Firewall, though I think that this is unlikely to call a bluescreen in an application program.


#9

Morning @rovf, we provide SHA1SUMs. Can you double check they match:
http://downloads.activestate.com/Komodo/nightly/komodoide/latest-12.0.x/SHA1SUM

As unlikely as it may be, please try disabling them before you download the installer. It is very common for anit virus to change downloaded binaries without telling the user, breaking them in unknown ways.

  • Carey

#10

While I’m not a big fan of MacAffee, I am certainly not permitted to disable the scanner, and even though I have local admin rights, I don’t think I can actually do it. However it is a good idea to verify the checksum after a download.


#11

Ok, understood. Did you confirm the checksum of the installer then? If yes, could you try running the following in a CMD Prompt.:
msiexec /l* log.txt /i "path\to\installer.msi"

You can email me the resulting log file at careyh@activestate.com.

Note that there are options to bypass the installer UI. If you want to try that after getting the logs above you run the following and hopefully we can just get your running and no longer debugging:
msiexec /l* log.txt /a "path\to\installer.msi"

  • Carey

#12

I downloaded the new version (Komodo-IDE-12.0.1-91854.msi), verified the Checksum, and found the same behaviour. This time I could manage to do screenshots before the bluescreen appeared:

The first screenshot shows the dialogue where I fix the installation directory; the default is some path ending in “… nightly”, and I changed it to the directory, where I have my previous installation of Komodo IDE:

capture_20200210_062814

After clicking OK, this is what I get:

capture_20200210_062909

You can see here on the titlebar already the message “Keine Rückmeldung”, which already tells us that things go wrong.

I will also try the msiexec command and upload its result here.


#13

The msiexec command you suggested does not work. It does not produce a log.txt, but just opened this message box:

This usually indicate that the program has been called with incorrect parameters, and indeed the text lists under “Protokollierungsoptionen”, that the /lib part in the command is wrong: /l accepts the ‘i’, but it does not allow the ‘b’. You can also see this from the screenshot.


#14

@rovf,

What command did you run? I did not include /lib or /b in the command. It’s /l for logging, then * to include ALL log output except verbose or “Extra debugging information”.

This command runs fine for me, please confirm you ran the same command by pasting your terminal session here:
msiexec /l* log.txt /a "Downloads\Komodo-Edit-12.0.0-18425 (1).msi"

I note that you’re trying to install Komodo ON TOP of another install. That’s likely causing the problem, though it shouldn’t crash. Could you try deleting the previous install before installing? Or just let it install to where it’s trying to install.

  • Carey

#15

OK, several things are much clearer now:

The ‘/log’ was basically my fault. My Zsh expanded /l* into /log before invoking cmd.exe; I should have noticed that.

More importantly, I got closer to the Blue Screen problem. Following your advice, I first erased the old IDE installation, but when I did a rm -rf from my Cygwin Zsh on this directory, this command caused a Blue Screen immediately. Perhaps, the installer also erases the directory first, and stumbles over this problem. After reboot, I erased the directory from Windows Explorer, which worked without Bluescreen, but I found that some files (example: lib\mozilla\chrome\en-US\locale\branding\brand.dtd) needed me to enter my administrator’s password, in order to delete them. I wonder why this is necessary, since not every user will have local admin rights, and I think this is the original cause of the problem: While Windows explorer asks the user for the necessary credentials, some Windows function simply respond with a Bluescreen if an application does an unlink of a file, instead of simply rejecting the request. If my theory is correct, this is of course a Windows bug, but still it makes me wonder why you are installing files which can not be removed with only user privileges.

Finally, when I installed the nightly build in a fresh directory, it worked well.


#16

@rovf,

Nice digging. One note, Cygwin is known to break many aspect of Windows and the programs that runs on it. Komodo is no exception. I’d be confident in saying that the problem actually lies there. As stated before, no one else is experiencing this issues. It’s a standard msi installer that hasn’t had this issue for year. The cause of the problem is most likely special to your computer. I’m not trying to deflect any responsibility here, that just seems like the most obvious answer. I could be wrong but I don’t think I am.

I get the feeling your are perhaps normally a Linux user? Installing without need for specially permissions is pretty normal on Linux but not Windows (though that is only for the current user). This is standard Window workflow. If you right click on any of the other programs in C:\Program Files (x86) you’ll see that for most of them, deletion requires admin privileges, which is where we default to. If you want to install Komodo somewhere where manually deleting it doesn’t require admin privileges you would change the folder to somewhere in %USERPROFILE%.

That’s great the nightly is working. We just release 12.0.1 and you should be prompted to auto-update to that soon.

  • Carey