Komodo IDE - Commando (Go To Anything) is empty

In my Komodo IDE environment the “Commando (Go To Anything)” is empty.
I always get an emtpy List. Whatever i chosse the result is empty.
Perhaps it is my fault. I choose “Clear Cache”.
I’m unable to update or install new packages for the Komodo IDE although there are packages installed.
The list “Installed Packages” is empty.
Is there a way to restore it?

Could you please access the old addon manager and enable any addon that is disabled? After that restart Komodo and try using Commando again.

Sorry for the late response.
I had access to the old addon manager, but all addons where enabled.
I had tested disabled all addons and do a restart and after that i had enabled all addons.
The same, i get an empty list.
After restart Komodo IDE a message say “update packages available” but the list is empty.
The old addon manager say there is no addon to update.
Anything is wrong with my Komodo, with my “Go To Anything”.
For instance i’m unable to find a file or run a shell command with “Go To Anything”.
Is there a way to reset “Go To Anything” to the original?

Try using Help > Troubleshooting > Restart in Safe Mode.

I have tested “Restart in Safe Mode.” Its works.
In Safe Mode i have the corret “Go To Anything” with all entries and full lists.
Back in Normal Mode “Go To Anything” is agin empty.
I’m unable to find out which package update is need.
The behavoir in Safe Mode is complete different from Normal Mode.
There are different configurations?

It does sound like you still have addons disabled, reading your response before again it also sounds a bit odd.

Let me explain it step by step.

  • Open the console pane in the bottom Komodo panel
  • Paste in (and execute): ko.windowManager.openOrFocusDialog("chrome://mozapps/content/extensions/extensions.xul", "Addons:Manager")
  • In the window that pops up, click on “Extensions”
  • Scroll down the list and anywhere you see the button “Enable” you click it.
  • Restart Komodo

Thank you for you step by step explanation.
I have follow excat this explanation, but there is really no button Enable.
I think the extension you mean is not in list.
Can you tell me which extension, addon or thing is to enable.
And yes it sounds a bit odd, that the resaon for this support question.
Can i send you same screenshots or logs?

Could you try recording a screencast that shows your addon list, as well as reproduces your problem?

I have made screencasts. You can find they under the follwing link:

In this case Komodo is start in normal mode.
The next screencast show Komodo in Safe Mode:

I have made same test and i think i have a corrupt prefs.xml under
Is there a way to restore it?

Can you PM me your prefs.xml and XRE/extensions.ini? I could try to restore it and see what add-ons are disabled for you.

Simply deleting the prefs.xml would cause it to be re-created the next time you start Komodo. Please do make a backup and consider sending it to us if removing it does indeed fix your issue.

You could also opt for completely resetting your profile: Help > Troubleshooting > Reset Everything.

Thanks for you reply.
I have made tests with deleting prefs.xml. Only deleting prefs.xml do nothing changes.
I have made tests with deleting prefs.xmlc. Than i lose my current configuration.
I also have made tests with “Reset Everything”. Its works, but all configuration is lose.
So i have use my backup of prefs.xml and prefs.xmlc. The problem is still the same.
How can I PM send you these files?

To clarify, you’re saying that “Reset Everything” resolves your issue, but then if you put back your prefs.xml the problem returns?

If that’s the case, please feel free to email me the prefs.xml at nathanr@activestate.com.

Yes “Reset Everything” resolve my issue, but with my prefs.xml the problem returns.
I have send an email to nathanr@activestate.com with this file.

1 Like

In there anything news or results?

Sorry for the delayed response, thank you for reminding me. Just had a dig.

Turns out you have Prefs > Commando > Max Results set to 0. Simply set that to something like 50 (default) and you’ll be good to go.

Yes, Max Results was set to 0.
With default value 50 all is good and works right.

Thank you for you work. It was a long way.

Two annotations.
I think it should be unable to set this value to 0.
The file prefs.xml is very large.
Maybe it should be split in more smaller files for “IDE Config”, “Workspace” and so on.
Perhaps it could be a feature form Komodo 10.0?
I think this issue can be set to solved.

Agreed, already fixed this on master :smile:

Agree with this also, but the theory is unfortunately much simpler than the implementation. Definitely something we’re looking into though.