Komodo Crash macOS Sierra


#1

Just bought a Komodo License.
macOS Sierra
Crashes every time I launch it since I added the license key.
Has anyone encountered this? What is the fix?


#2

@dave.goodnat,

First thing to try would be to move your profile aside. I don’t know enough from your post to be sure what’s going on but a corrupt profile can cause issue.

Profile can be found at ~/Library/Application Support/KomodoIDE/10.x. You didn’t say what version you’re on so I’m not sure what x should be.
Ref: http://community.activestate.com/faq/komodo-file-locations#appdata_dir

Move the KomodoIDE folder aside then start Komodo and see if that helps. This won’t effect your license so you don’t have to reinstall it.

If that doesn’t help please provide more details.

  • Carey

#3

Moved Folder Aside. Still Crashing.

Crashes at Launch. Goes directly to Crash Reporter.

AdapterDeviceID: 0x67ef
AdapterDriverVersion:
AdapterVendorID: 0x1002
Add-ons: analytics%40activestate.com:1.0.0,bazaar%40ActiveState.com:1.0,breadcrumbs%40activestate.com:1.0,commando%40activestate.com:1.0,console%40activestate.com:1.0,dbexplorer%40ActiveState.com:1.0,domviewer%40ActiveState.com:1.0.0,editorconfig%40activestate.com:1.0.1,fontawesome%40activestate.com:1.0,git%40ActiveState.com:1.0,golang%40activestate.com:1.3.3,httpinspector%40activestate.com:1.0.0,icomoon%40activestate.com:1.0,klint%40dafizilla.sourceforge.net:1.4.0,koextgen%40activestate.com:0.2,komob%40activestate.com:0.4.3,markdown-viewer%40activestate.com:0.3,mercurial%40ActiveState.com:1.0,openfiles%40activestate.com:1.0,perldevkit%40ActiveState.com:8.0,profiler%40ActiveState.com:0.1,publishing%40ActiveState.com:1.0,railstools%40activestate.com:0.3.1,refactoring%40activestate.com:0.1,tcldevkit%40ActiveState.com:5.0,trackchanges%40activestate.com:1.0,zendframework%40ActiveState.com:0.8,check-compatibility%40dactyl.googlecode.com:1.3.1,elastic-tabstops%40activestate.com:0.1,focusmode%40activestate.com:1.0.2,komodospellchecker%40ActiveState.com:1.0,kopy%40activestate.com:1.0,lintresults%40activestate.com:1.0,runinline%40activestate.com:1.0,scope-bookmarks%40activestate.com:1.0,scope-combined%40activestate.com:1.0,scope-commands%40activestate.com:1.0,scope-docs%40activestate.com:1.0,scope-files%40activestate.com:1.0,scope-openfiles%40activestate.com:1.0,scope-packages%40activestate.com:1.0,scope-sections%40activestate.com:1.0,scope-shell-bower%40activestate.com:1.0,scope-shell-composer%40activestate.com:1.0,scope-shell-cordova%40activestate.com:1.0,scope-shell-cpanm%40activestate.com:1.0,scope-shell-docker%40activestate.com:1.0,scope-shell-gem%40activestate.com:1.0,scope-shell-grunt%40activestate.com:1.0,scope-shell-gulp%40activestate.com:1.0,scope-shell-npm%40activestate.com:1.0,scope-shell-phonegap%40activestate.com:1.0,scope-shell-pip%40activestate.com:1.0,scope-shell-ppm%40activestate.com:1.0,scope-shell-pypm%40activestate.com:1.0,scope-shell-vagrant%40activestate.com:1.0,scope-shell%40activestate.com:1.0,scope-tools%40activestate.com:1.0,tutorials%40activestate.com:1.0
BuildID: 89510
CrashTime: 1481750618
EMCheckCompatibility: true
Email:
EventLoopNestingLevel: 1
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1481742643
Notes: AdapterVendorID: 0x1002, AdapterDeviceID: 0x67ef
ProductID: {36E66FA0-F259-11D9-850E-000D935D3368}
ProductName: Komodo IDE
PyxpcomMethod: {368e9fb1-8bc7-4e77-a3cf-6c21e87e26d4}::setOnTop
ReleaseChannel: release
SecondsSinceLastCrash: 7014
StartupTime: 1481750614
Theme: classic/1.0
Throttleable: 1
Vendor: ActiveState
Version: 10.1.3
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.


#4

Uninstalled and reinstalled. Same issue.


#5

Can you send in a crash report (when prompted) and let us know what email address you used?


#6

Komodo Edit 10.1.3 also crashes on launch on 10.12.2 (I was running 9 so I don’t have any profile info for it at all)

Komodo Edit 9 crashes whenever you try to close a file - it was fine on macOS 10.12.1 but has broken with 10.12.2. I’ve sent several crash reports for it.


#7

Please use 10.1.3, it fixed the most common crashing issue.

As for continued crashes after an 10.1.3 upgrade, please send in the crash reports and fill out the comments and email fields so the crash is actionable for us. Crash reports without context are all but useless.


#8

10.1.3 is what I’m using already.

Crash report sent under name dave.goodnature@sbfnet.com.

Comments and fields filled out.

Please advise. I just bought this license. If this is indicative of the issues with this software, I will be demanding a refund.

Thank you.


#9

I too am trying 10.1.3 of Komodo edit and have sent in crash reports. Seriously impacting my work. V9 works enough to continue but is unstable.


#10

#11

Thanks @Defman, forgot about this one :slight_smile:


#12

np :wink:


#13

So how do I get a version that will run on my Mac today?


#14

Seems like the only way would be downgrading your 10.2.2 to 10.2.1 or wait until tomorrow (there will be a nightly tomorrow likely)


#15

The current version is the only one I have ever downloaded or installed on this Mac. I’m not sure where to access older versions.

PS - I really appreciate the help.


#16

@dave.goodnat we have a fix and are running a nightly build, hopefully we’ll have a nightly available later today that you can use. Until then there is no fix or workaround besides using an older version of OSX.


#17

Thank you.

Where do I go to get the nightly builds?


#18

http://downloads.activestate.com/Komodo/nightly/


#19

I appreciate the assist. Appears to be working fine. Gracias.