Komodo 10 Curly Brace Behaviour

I’m struggling with the behaviour of my newly installed Komodo Edit 10.1.1. I’m editing a TCL file and when I type a curly brace, it is moving it to the next line down and adding the closing brace on a line below that…

set a_variable 


When what I actually need is to set the variable to be an empty pair of braces…

set a_variable {}

I’ve tried all the auto-complete options that I can find in the preferences but nothing seems to work. How do I turn this off?


Did you install Allman Braces perhaps?


Not that I am aware. The addons window only shows font-awesome installed. Allman Braces Extended is listed in the tools but nothing happens if I right or left click on it. I find the new addons window very unfriendly so I used the legacy addons window and that shows a whole heap of things - none of which is called Allman Braces. I’ve been through and disabled several and that seems to have cured the behaviour. It’s not very intuitive is it?

Allman braces is not an addon, it’s a userscript. Delete it from your toolbox and restart Komodo, your issue should be gone.

Ah got it. That’s the toolbar on the right. It’s not one I usually have open other than for FontAwesome. Thanks for your help.