Komod IDE hangs when working from a slow internet connection

I’m working from a slow internet connection and high latency. The file(s) I’m working on resides on a remote computer.
I fully understand that saving files will be slow, however Komodo IDE hangs several times even AFTER I have saved the file. This does not happen when my connection is good. And I would expect that the internet connection should not impair my ability to work on the file apart from when I have to save it. However I have the impression that other on-line operations are going on and the IDE is blocking while this happens. I have tried to disable several notifications but to no avail. It is rather impossible to work, as the IDE is hanging for 30-40 seconds at a time.
Do you have any suggestion for how to work around this?

Tia, Paolo

Hi, try disabling Track Changes (Edit > Preferences > Smart Editing). That’s the only one I can think of at the moment.

Are the files mounted through your system or are you accessing them using the remote functionality in Komodo?

If the former, are they under version control?

Thank you will do. I’ll let you know how it goes when the connection gets again slow as it was yesterday evening. I found out that there is a kind of threshold above which Komodo IDE gets unresponsive (the unresponsiveness does not seem to be directly proportional to the sluggishness of the connection).

They are remote, I’ve already disabled version control in Komodo.

This does not answer my question. Both options are remote, I’m asking whether you are using Komodo to set up your remote connection or something else?

the files are not mounted through my system. I’m working from a Windows laptop, accessing files on a remote linux server through Komodo’s SFTP connection.

Alright, thanks for clarifying :slight_smile:

Let us know if disabling Track Changes had effect.

hey @tribis,

This sounds like Preferences > Editor > Confirmation Dialogs: Detect when files are changed… or Detect when networked files are changed.

I would try disabling networked first. If that doesn’t help try the other.

  • Carey

Yeah, it makes much sense. And for some reason I didn’t disabled that yesterday. I’ll try it today.
I’m waiting for a worsening of network conditions to have the same clear picture as yesterday, then I’ll get back with some results.

Cool, let us know @tribis.

  • Carey

“Unfortunately” networks conditions have not been as bad as last Sunday, however I think I have come to a fairly certain conclusion about what happens.

The setting that solves the problem for me is: “Detect when networked files are changed” as suggested by @careyh. The rationale is as follows:

I work switching all the time from Komodo IDE to a terminal window and a browser window. A terminal window for running javascript builds and the browser window for testing things with firebug.
Now, the critical thing is that when “Detect when networked files are changed” is on, Komodo blocks the IDE each time I return focus to it from another window, no matter if nothing has changed or moved in any way. Probably some background check through the network of some kind.
This is annoying by itself. However when the network latency is high, this stop is longer and causes window to spin the cursor and even make the screen opaque.

As far as I remember from last Sunday, this hanging of the IDE did also occur on some occasions independently for me giving focus back from another window, but due probably to much better network conditions I couldn’t reproduce this during these days.

Thank you very much for your time and attention