"Indentation" preferences for XML have gone from bad to worse

I’m using Komodo IDE v 9.3.2. Even though my global preferences and file preferences specify an indentation of 2 spaces and to use spaces rather than tabs, the editor still insists on adding tabs. The only way I can get tab-free indentation is to invoke the “untabify” menu command.

It was bad enough that the per-language indentation preferences were not saved (at least for XML), that bug has been present for too long already. Those preferences are now, in v9.3.2, ignored altogether.

A significant amount of work has gone into fixing these bugs relating to indentation preferences. Could you clarify exactly what bug reports you’re referring to, re: [quote=“csid_tom, post:1, topic:2664”]
It was bad enough that the per-language indentation preferences were not saved

Could you try the latest nightly of Komodo 10 as well and see if the issues are resolved for you? FYI, the latest nightly will be available at 12pm PST, ie. in about 19 minutes. http://downloads.activestate.com/Komodo/nightly/komodoide/

  • Carey

I’m using Komodo Edit 9.3.2 on OS X 10.9.5
I don’t have the problem mentioned above with tabs being used - Komodo correctly converts tabs to spaces for me.

But I do see a problem once in a while with indentation where the auto-indent-upon-newline seems to insert about 20 spaces instead of the 4 spaces that I have configured.
In previous versions, this kind of problem also occurred once in a while, but in those previous versions it seemed that the problem was that the per-document settings had somehow gotten changed (without me doing it) and the fix was to specify the 4 spaces config in the per-document settings.

But currently, when this problem occurs, the per-document settings don’t show any problem. I haven’t found any fix for when this problem occurs in the current version of Komodo Edit - I have to manually delete the indent and insert the desired number of spaces manually. The problem seems to go away on its own sometime later - maybe after Komodo Edit has been restarted?
This problem occurs only once in while (maybe once every 3 weeks) so it isn’t useful to try the overnight build to see if it exists there.

I don’t have the tickets at-hand at the moment, I’ll try and find them though.

I’m running Komodo Pro v9.3.2 on Windows Pro v7.

The issue I’ve seen for awhile is that I want 4-space indents for everything except .xml files, and 2-space indents for those. As I recall, for a time, I could get the special 2-space indent to “stick” during the editor session where I provided it. It would, however, disappear after closing the IDE. When I reopened the IDE, .xml files would again be set to a 4-space indent.

More recently, perhaps in the past year or so (?), the per-space indent setting for .xml files has had no observable effect at all.

This is readily demonstrated on my IDE:

  1. Open global preferences, navigate to “editor->indentation”, set the “Per-Language Indentation Settings” drop-down to “XML”, enter “2” and “2” for “Number of spaces per indent” and “Width of each tab character”, and make sure “Prefer tab characters over spaces” is cleared. Click “OK” to save changes.
  2. From the “File” menu, select “New->XML.xml”.
  3. In the resulting file, select “Edit->Current File Preferences…”

The resulting dialog contains “4” and “4” as the values for the two fields, rather than the correct values of “2” and “2”.

The new (with v 9.3.2) behavior is that, even though the “Prefer tab characters over spaces” setting is cleared (not checked), typing the tab character in the new file inserts a literal tab rather than the requisite number of spaces.

This unwanted behavior is the same for existing .xml files.

Is it 8 as apposed to 20? That issue has been resolved in Komodo 10. We discovered that in some of the older Komodo code it was setting users file level preferences for them without the user knowing. We’re trying to remove that code and it has unfortunately results in unforeseen bugs, most of which are resolved. One of those changes was introduce in 9.3.2 so this makes sense for your case, @hayne . I’d suggest trying Komodo 10.

@csid_tom, Can you also try Komodo 10? I’m pretty sure your issue is resolved as well.

  • Carey

This still happens sometimes in 88986, but @mitchell has fixed it, so I suggest to wait for a new nightly.

I will when I can. I’m on a release deadline at the moment. I appreciate your attention to this, thanks!


Did you mean to mark your last comment as “Solution”? I don’t see a solution in [quote=“Defman, post:6, topic:2664”]
This still happens sometimes in 88986

The latest nightly is 89034

We really appreciate your patients then! and your feedback.

  • Carey
1 Like

Good to know, I’ll update now! :slight_smile:

Hell yeah this release fixed all my indentation problems! @mitchell you rock!

For what it’s worth, Komodo 9.3.3 should have fixed some indentation problems introduced in 9.3.2. If Komodo 10 is “too alpha” for you, you may want to try updating to 9.3.3. I’m not entirely sure your problem will be fixed though.

Where can I get the 9.3.3 version? It’s not on the website and my IDE says there are no updates.

I stumbled on this, cause I just got (again) angry cause the per language settings are not working as expected.
Just for info, my settings are Indent 4 mainly for Python, but i want only 2 for JS, HTML, HTML5 whatever…it only gives me 4 :frowning:
And I’m on Komodo IDE 9.3.2 on Win7

br, Michael

Sorry, I was wrong about 9.3.3. We only released nightlies for it, but they are no longer available :frowning: Sorry for the confusion.