ImportError: No module named cile_haml and LangInfoError: no info on u'Haml' komodo lang KOMODO IDE 9

Hi!

I have this problem when intent create language extension of .haml, HELP ME PLEASE!!!

  1. Download Haml UDL zip of official website.

  2. I Unzip Komodo UDL and create in KOMODO 9 Language Package.

  3. I do not understand what they are for many things, but the language does not help me pack komodo haml default and when I pack my own language I leave these errors

I’ve downloaded the package. Just drag’n’drop haml_language-0.1.1-ko.xpi onto Komodo window to install it and restart Komodo. Not sure if the add-on will works with Komodo 9 but I hope it will. Don’t build it for yourself until you have some experience in UDL, Python and Komodo add-on development.
BTW there’s a HAML syntax highlighting for Komodo created by Eric Promislow, a Komodo developer: http://komodoide.com/packages/languages/haml-syntax-highlighting/
Install this via Package Manager rather than trying to build the add-on you want.

I have tried install haml_language-0.1.1-ko.xpi but it was has imposible. No run perfect. Help me please

Instead I have tried development package language with UDL and it works, but show me error

Help me

Please try that. http://komodoide.com/packages/languages/haml-syntax-highlighting/
I don’t know what is “development package language with UDL”.

It not work, I have tried but it not work :frowning: :frowning:

@mitchell can you say something on it? It’s a problem of the add-on but I don’t know what it means to fix it. (not a pro in UDL and languages structure in Komodo)

Ahh, nevermind. I’ll fix it manually, got the problem.

1 Like

I’m not able to reproduce any of your errors using the latest nightly. Just ignore these errors.
The problem (I guess): https://github.com/Komodo/KomodoEdit/issues/286 (fixed)

Work? How. What is your versión KOMODO IDE? works it haml extension?

Komodo IDE, version 9.2.1, build 87651, platform linux-x86_64.
Built on Wed Sep 2 01:52:41 2015. using the add-on I suggested.

I am going to re-install KOMODO. :frowning:

Just use the nightly. http://downloads.activestate.com/Komodo/nightly/komodoide/latest/Komodo-IDE-9.2.1-87651-macosx-x86_64.dmg

Do you work the haml code ckechers? I dont have the problem messages, but codelinter no work! :frowning:

Seems like there are a lot of problems with the add-on. If I find some time I’ll try to fix some of the errors.