How to make komodo use python3 as defaukt


#1

I am using komodo-edit 11.1.11 on MacOS 10.14.6, and whenever I open a python project (or restore an old session), the “View as language” is always choosing python, and not python3. I always have to change it to ‘python3’ to avoid e.g. f-strings to be marked as an error.

How to change the default “View as language” settings for python (or remove python[2] altogether)?


#2

@alex7755, you can adjust this in *Edit menu > Preferences > File Associations.

Will likely update this in the next release.

  • Carey

#4

Just to make sure: This feature does not work yet? I still have to change the file asociation to Python 3 manually for every single file?


#5

@alex7755, no, all NEW Python files should be picked up as Python 3 when opened, assuming they don’t have a shebang to contradict that.

If you have a ton of files you’ve already opened in Komodo and were detected as Python 2 you should be able to delete doc-state.xmlc from your Komodo profile to reset file level prefs and have Komodo re-detect file types.

Ref for profile location: Important File Locations

  • Carey