How to get Publishing to ignore EOL differences

I just downloaded Komodo IDE 10 trial, I was hoping to buy after trying it out if I can’t auto-upload to my dev environment then I’m not buying. Auto-upload is done by Publishing, everything seems to be setup correctly but when I run my first synchronization I get tons of files with conflicts (when they should none - I used other tools (Putty and Git GUI) to make sure both my computer and my development are on the up to date master branch). I looked at several files and the only difference between files are the line endings (my local computer is running windows my dev environment runs on Linux), if I use other tools like winSCP or FileZilla to upload the whole repo no issues, they fix the line endings to correct type when uploading. How do I get Komodo IDE Publishing to do the same?

Note, while looking through Komodo IDE documentation I did find a setting for EOL. I’m aware of the “new file” settings were you can choose default EOL type but what about existing files when uploading?

And sorry in advance, I’m completely new to Komodo IDE 10.

It’s not the line endings otherwise you will always have this issue every sync. If it’s your first sync then Komodo has no record of a previous state so it’s making assumptions that things are different on local and remote (not sure exactly what your conflict message is but I’m guess it’s “both changed”). Just force push or force pull all the files.

Unfortunately Komodo assumes you populated either the remote or the local using it’s sync counterpart. It sounds like you had both populated then setup publishing.

  • Carey

“Remote and Local are modified. Resolve conflict.” is the conflict message.

I did have remote and local already setup before I got Komodo IDE, makes sense. Thanks, I’ll try forcing it and see how that goes. :slight_smile:

Nope, no go, won’t allow force pull or push until I resolve ALL of the conflicts (which is normally a good thing but in this case it’s crazy that’s thousand of files I’d have to change the line endings for by hand - not happening!). It seems like the root of the issue is some Komodo IDE setting I don’t know about or need to find a way to pick up an existing setup for Publishing rather than create a new one - if that makes sense.

Well there you go, I forget how to use the code I write (shakes head and am not being sarcastic). Try Select All > Right click > resolve push or something like that. I don’t have a Publishing configuration setup or a VM running to test but I’ll look now. Try the above in the mean time.

  • Carey

GAh, there is no “Select All”, it’s Check All". You’ll have select the first item, scroll to the bottom, hold shift then select the last one. That should select all your files. You can then Right click > Resolve Conflict > upload the local file.

Sorry for the confusion @23MFreckles.

  • Carey