How to get Komodo IDE 8.5.4 to only stop at the breakpoints I set?

I’ve got remote debugging setup properly. (I think, anyway.)

But the breakpoint I’m setting is pretty deep within the codebase. The problem is that komodo wants to start at the very first function and I have to either step in or over to get where I want to be (which is much deeper than the beginning of things).

Is there some trick to getting the debugger NOT to stop until the breakpoint?


Hi @aaronELBorg,

You’re looking for Preferences > Debugger: Initial break behavior: Run to first breakpoint

  • Carey

Thanks for the reply, Carey. I’m not seeing that particular choice under my preferences, unfortunately.

I’m in 8.5.4.

Thanks again.

It’s there assuming you’re using Komodo IDE (don’t know why you would be asking about debugging if you weren’t). Here’s a screenshot from Komodo 8.5.4:

  • Carey


Man…how I missed that I have no idea!

You, my friend, have saved the day.

Many thanks.

1 Like

Thanks! Good luck with your project.

  • Carey