How to disable the multiline/multicaret editing?

When trying to code on Python, I am often bugged by a multi-carret when closing a tuple with a string inside:


After typing the ending ', the ) is added automatically (ok…) but another caret is added just before the 1st ', and I need to stop and fix any mess before keep coding.

I already disabled everything about multiline/multicaret that could be found on the preferences, but this still happens.

Is there another way that I can be missed?

You want Preferences > Editor > Smart Editing > Enable soft characters

And if that does not work, try Edit > Preferences > Editor > Smart Editing > Edit Matching Delimiter on Select.