How To Best Report Crashes

Komodo 10 crashes on me 1 to 4 times each day. I’m wondering what the best way to report these would be? Should I just the Report A Bug button and attach a log file? Does the dev team already automatically receive crash dumps each time this happens?



Best means to report a bug is through Github.

We receive the bug reports if you get the crash dialog but we do not proactively follow up. There is no context of what the user was doing with those reports and they don’t contain very much information oddly enough.

A bug report with exact steps to reproduce the crash is the best method.

  • Carey

@careyh What recommendation(s) do you have if the crashes are not reproducible? I’m seeing at least a couple crashes each day, typically when Komodo is not in active use (i.e, just sitting in the background with files open while I deal with stuff in other applications). I can’t say it definitively, but I don’t think I’ve had the current release crash yet while I am actively using it – only in the background. I’ve grabbed the logs before restarting and there’s really nothing that I can see in there that seems common to the crashes or indicative of problems.

If those crash reports are not useful to your team and are not actively reviewed, I’d recommend removing that logic from the application as it certainly gives the (apparently false) impression that there’s some value in submitting the crash reports.

FWIW, I’ve had slightly more uptime by disabling debugging - something of a deal-breaker for many IDE users, I know.

@neurobashing you’re only disabling remote debugging – an application initiating a debug session with Komodo. You can still use Komodo to start debugging applications.

@neurobashing Which settings specifically are you changing when you disable debugging? I don’t currently use debugging within Komodo IDE, so that’s not a loss for me.

unchecking Debug->Listen for Debugging Connections seems to give me a very big stability boost; I’ve gone from 3-4 a day to 1 every 3-4 days. I also made sure to disable every possible addon I didn’t need to get work done.

(It’s in the Github thread about this but I can’t seem to disable it from a startup script, but that’s not a deal-breaker)

Need to reiterate what @mitchell said above. This does NOT disable local debugging. You can still debug you program from within Komodo. Turning off the debug listener only prevents remote applications (starting the program from the commandline rather than from Komodo) from contacting Komodo to start a debug session.

This shouldn’t be a deal breaker for a majority of users.

@Gewurtzraminer, Has your question been answered? Do you have more?

  • Carey

Hey @rstewart and @Gewurtzraminer ,

To answer your question further:

Check Help > Troubleshooting. There are many options in there to help you to reduce the number of variables that could be contributing to the crash. For example, as @neurobashing said, you could remove all unnecessary addons until the crash stops happening. You can then start adding them back.

Look on Github for someone that might have reported the same issue. Ie. the one @neurobashing keeps eluding to:

Contact us here in the forums and depending on the symptoms we might have some other ideas. Give us as much information as possible. We’ll work with you to try and figure out what the issue is.

Having said that, sometimes the issue is extremely elusive which is the case with the bug I shared above. Even crashreports aren’t telling us whats going on. We’ve compared multiple crashreports from people reporting that they experience that issue and they do not match at all.

I hope that’s helpful!

  • Carey

A bit of follow-up here, related to continued crashes: about 10 days ago, I switched from running the latest official IDE to the latest official Edit, configured as close to identically as possible (same UI layout, same color schemes, same editor settings, same extensions, etc.) and I’ve not had a single crash since switching.

I know that doesn’t narrow the cause of the continued crashing down much, but it would provide at least an anecdotal indication that it is being caused by something in or related to the IDE-specific capabilities.

I did see that a nightly build was just pushed out for the first time in a couple months. I may try running that version of IDE for a few days and see if the crashing problem is still present. I at least have a much less crash-prone fallback in Edit, if needed.

Thanks, that is helpful information, even if vague.

For anyone having crashes on OSX, try that:

$ defaults write com.activestate.KomodoIDE NSAppSleepDisabled -bool YES

(Thanks to pemcg)

This solution will be included in 10.1 which will be released very soon, so the devs would want to see if that helps.