How can I get Komodo X to debug PHP 5.2?

I am supporting an old project that’s currently using PHP 5.2. Here are the relevant lines from Komodo’s log when I try to turn on debugging:

[2016-06-07 13:45:16,954] [ERROR] koAppInfo: PHP command timed out: [u'C:\\server\\php\\php_5_2_17\\php-cgi.exe', '-q', 'c:\\users\\fakeuser\\appdata\\local\\temp\\tmpvhgyoo.php']
[2016-06-07 13:45:16,954] [ERROR] koAppInfo: could not determine PHP version number for 'C:\server\php\php_5_2_17\php-cgi.exe':

If I run php-cgi.exe --version from the command line, PHP 5.4 & PHP 5.6 return immediately and debugging works for both of them but PHP 5.2 takes a few seconds, which I suspect is why Komodo is failing to find it. Is there a way to increase Komodo’s timeout when checking the PHP version, or get it to skip the check entirely?

For instructions on how to set up debugging see our docs:

Let us know if you are having trouble with some part of these docs.

The part I am having trouble with is when I have followed the steps exactly and it doesn’t work. Both PHP 5.4 & 5.6 work perfectly but PHP 5.2 doesn’t work at all. I have already provided Komodo’s error log about this issue so I don’t know what else I should do at this stage.

Hi, the timeout is hardcoded at 5 seconds, so if PHP 5.2 is taking longer than that to initialize, I’m not sure there’s anything you can do :frowning:

@mitchell is it hard coded by us or by a third party? If the former, can we make it a (hidden) pref?

It’s hard-coded by us. We’d have to make it a preference.

Opened a bug for this here:

Note that in the next Komodo update we will be dropping support for PHP 5.2 and 5.3 debugging. This does NOT mean you will not be able to debug these versions anymore, it just means we won’t be shipping the debugging bits anymore. This only really affects users that use local debugging for these PHP versions, if you are using remote debugging (most PHP users would be using this) then you will be unaffected by this change.

Reading through this thread I don’t believe this should affect you at all, but I thought it was worth noting.

@CJ.Dennis @mitchell just pushed a commit that adds a new hidden setting allowing you to set timeout for php commands (especially running xdebug).

It will be available soon, to change it open Console pane and execute this:

require('ko/prefs').setLong("phpGetOutputAndErrorTimeout", TIMEOUT_IN_SECONDS)

1 Like