Go path issue, and now license issue

So I wanted to try out Komodo just to see how it fares with Intellij, I just downloaded today on my Yosemite OSX, at first it asks for the license, and I opted for the 21 days to check things out.

  1. Go support does not work, as Komodo keeps forgetting where Go is installed.

  2. Once I got home, opened up my laptop, the license screen shows up again, asking me to:

    • Upgrade/renew
    • Download license
    • Visit Activestate

Whatever I do closes the IDE. Not even a day have passed and I can’t use it already.

The Go issue is being tracked here - https://github.com/Komodo/KomodoEdit/issues/58. It includes a workaround.

Apologies for the inconvenience

Would be worth trying the steps in this FAQ on Komodo Trial License issuesas well.

I tried to remove all the kodomo artifacts, and replace the kodomo app, and I got the 21 day license prompt. Unfortunately, it fails again now asking for a valid license.

I’ll ask sales, but I believe someone must fix this as this should not be the way for this software to run.

What are you doing between starting the trial and it “expiring”? Anything out of the ordinary?

First was install at work open a few times ok, bring laptop home, open it there license issue.

Second try, delete Komodo stuff + reinstall app, worked twice, go to office, reopen there, license issue.

That’s very odd. I’m assuming you’re on WIFI? Will dig and see what I can find.