Error/Warning when duplicating file

When I am in Places and I copy and paste a file and select copy as new name, I fill out the name, and after clicking ok, I get this message:

I’ve tried this on Windows and I just had Nathanr try a few different things on his Linux machine. We’re not able to reproduce any issue.

You’ll need to give us more information:

  • Where are the symlinks that weren’t copied and where do they link to?

  • What is your OS and it’s version

  • Does this happen with every file you try to copy? If no, can you try to find a difference between those files that seem to be causing the issue?

  • Carey


I am trying to copy and paste files in the remote folder in Places. They are not symlinks and I don’t know why it thinks they are. It says the same thing for folders. So for now, I just have been creating a new file, then copying and pasting code from other file, then modifying, then saving/uploading. A little tedious, but that’s my only work around for now.

I am running Ubuntu 15.0.4.

Yes, with every file and folder including different servers.

Telling us they are remote files is definitely a start :smile:.
I don’t know why it mentions symlinks either. Are you still using just FTP for the connection protocol? Could you try SFTP if you are not already?

Open Preferences > Servers: open the server you’re currently using and change it’s Server type to SFTP.

  • Carey

Our servers don’t have SFTP enabled and enabling ssh access isn’t a good idea.

I can try on a test server or my local machine if you need me to.

I guess SSH is enabled on this one sever I am working on, strange.

It appears to have reconnected so I guess it’s using SFTP.

Here is the message I get now:

There is nothing wrong with enabling SSH if it’s properly managed unless you have some specific security concerns.

You said you’re uploading a file manually to perform the “copy”. Are you using an external tool for that?

More interesting error on that image. Looks like one of the params for the function is Null. I’d be interested in what the logs might tell us. Reproduce the issue then grab your logs and paste then here: Help > Troubleshooting > View Log File.

  • Carey

Enabling SSH/SFTP for a client allows that user to have ls rights to the entire server. You won’t have permissions to modify or create files, but you can view them. The next thing you would do is privilege escalation. I am pretty sure we can do this by finding the password files and decrypting them with tools like hashcat. Once you obtain the password, SSH back in with root and the password and now you have su access to the entire server. Not sure if there is a way around that, but it’s in cPanel so I don’t see any other option to prevent this.

I am copying and pasting within the same folder in the Places section within the Komodo app.

Here is the log regarding the issue:

[2015-07-17 14:45:20,019] [ERROR] koPlaceTreeView: doTreeCopyWithDestNameAndURI_WorkerThread: can’t copy file /subdomains/git/framework/ to /subdomains/git/framework/README uncopied_symlinks
Traceback (most recent call last):
File “/home/mjbrancato/Applications/Komodo-IDE-9/lib/mozilla/distribution/bundles/”, line 2788, in doTreeCopyWithDestNameAndURI_WorkerThread
self._copyRemoteItem(conn, src_rfi, newPath, requester_data)
File “/home/mjbrancato/Applications/Komodo-IDE-9/lib/mozilla/distribution/bundles/”, line 2730, in _copyRemoteItem
KeyError: ‘uncopied_symlinks’

I guess I don’t know you’re use case but no, you wouldn’t give random people SSH access to your server, nor was I saying you should. This isn’t an appropriate arena for this discussion any way.

It looks like copy is broken in Places for remote files. I’ve filed a bug:

  • Carey

Thank you for finding and filing that bug. I really appreciate it.

I didn’t mean give people random SSH access to the server. I meant the client. If you give a client access, then they have access to all the files including other clients sites. But of course not meant for this discussion, just saying.