Disable source control for a project (project-by-project basis)

Is there a way to tell Komodo “don’t use source control for this project, even though you found a .git/.hg/whatever dir in it”?

Problem: our dev env is a VM (for each user), and we mount the repo locally via smb or sshfs, usually. Even over the LAN, it takes several seconds to git status or whatever; over VPN from home, it’s nearly a minute, sometimes more. So everyone has the habit of just working with git from the shell on the dev itself.

What I’m seeing is: first, Komodo is crashing for no obvious reason, usually in the background, several times a day. Also, I’ll go to do a git operation and see either 1)index.lock for no obvious reason (i.e. I haven’t run a git command in a while) or 2)the repo is screwed up (shows everything deleted, etc). Both are easily fixable; there’s no data loss, but it’s problematic and scary, even though I’m getting used to it.

My thought is that Komodo is doing source control operations on the project in the background, and because it’s over a network share, it’s encountering a problem and dying (or in the latter case, giving up in the middle of something, leaving Git in a weird state).


BTW: Komodo IDE, version 10.0.1, build 89222, platform macosx.
Built on Thu Jun 9 01:54:55 2016.

There’s no such a preference but it’d be a good enhancement. Would you want to file it in the bug tracker?

You can disable VCS globally (via Prefs > Source Code Control), but there is no way to disable this on a project basis at the moment. Given the way VCS status works I think this would be hard to do.

You could create a simple userscript that toggles the pref though, eg.:

var prefs = require("ko/prefs");
prefs.setBoolean("gitEnabled", ! prefs.getBoolean("gitEnabled"));

I can’t find ‘disable’ but I did turn off ‘check for status changes from outside of komodo’ in Git, so I’m hoping that’ll fix the crashes and the weird crashed Git processes.

It’s the “Git Integration” checkbox at the very top of the Git Prefs window. If disabling status checking works though then go with that obvs.

  • Carey

haha, duh. as we say back home, “if it was a snake, it would have bit me”.


Ok so experiment not going well. I disabled all source control checking, and I still get once-or-twice daily crashes. Same thing every time: I’m doing something else (using the terminal or just AFK) and I see the crash reporter. I removed any add-ons and disabled everything I don’t need in the legacy manager.

The only think I can think of is the (#!#%&!*#&$) sshfs we share out from our dev machines. But our work network is pretty fast and the VMs are usually quite stable. And I would think that @ idle, it wouldn’t fire any events that act on a buffer (syntax checking etc); and even then, the file is at least in memory or a local temp file somewhere.

I’m at a loss here. Is there anything else I can poke to see if I get a result? I hate to file a bug that just says “Komodo crashes all the time”.

I’m guessing since your crashing is happening in the background, there really isn’t a rhyme or reason for it. We have a ticket for random crashes that isn’t yielding much fruit (https://github.com/Komodo/KomodoEdit/issues/1007), but if you’d like to throw your hat in the ring, it wouldn’t hurt.

If you are not using remote debugging, try turning off “Debug > Listen for Debugging Connections”. For my part when I get random crashes, it usually involves a remote debug session, but maybe it can still cause trouble for you.